Problem with models imported into 3DS Max


I am taking a shot in the dark here, I have yet to get help from Autodesk on their forum and a different forum. I am having a major issue in which after I import my Sketchup model into 3ds max and I UV unwrap my object I see a ton of extra random polys added to my model and some lines on the border of some parts of the model are gone. Basically it is an unusable model as when I try to go into and use my texturing software it shows those random polys as black spots.

I hope someone can help guide me on this issue as it is very annoying and makes Sketchup sorta useless to me as I need it to create models that I can’t create accurately in 3DS Max. The below picture is a screenshot of my texturing software after the model is finished.

Any help is greatly appreciated,


The first thing I would do in SU is go to View->Hidden Geometry and turn it on. Are there dotted lines where you’re seeing those diagonal lines? I’ve seen that kind of “shattered surface” before, but it’s not obvious without hidden geometry turned on. If SU doesn’t show them then maybe its the translation.


Hi RTCool,

Yeah I did that and even went through 3ds max to make sure and in SU I did not see any lines like that but in 3ds max I did… I am so confused. I have never seen anything like the pic you have, how would you go about identifying the issue causing it? What I hate is that I know they’re their, I just can’t find out how to get rid of them.

Here is my file, I don’t know if you would be able to display the polys.

Doghouse.skp (101.2 KB)

It looks to me like a problem caused by the coplanar faces of the window. I think if you made a better, more realistic doghouse model, you’d have better luck with it.

How are you planning to use this dog house? What’s the end use?

I just created that yesterday in about 30 minutes as a test to see if it was a problem with my other model. My other model of a relatively large building had the same issue and it had no windows. An entire 20 foot long wall was blacked out in many places like the dog house.

Another thing is that if I insert the model in 3ds max and UV unwrap either of them I can see many extra polys like RTCool has in his picture, but I can’t see them on my model in Max or SU, just when I UV unwrap them and then export them into PS for texturing.

It is extremely odd and I can’t make sense of it.

I think I remember getting help from you on Photomatch for the model below (thank you again there):

Shop Model.skp (116.8 KB)

I’m thinking you’re going to need to be asking the 3DS Max folks on this. Your shed model renders just fine in Kerkythea. I obviously didn’t add any materials to it but I wouldn’t do that in the renderer anyway. I apply materials in SketchUp instead.

What is your goal for this shed model?

I think the only way you could notice is if it is on a UV or when it’s ready for texturing. So yeah I am stuck, ill email Autodesk as their forums are comatose.

I am just practicing for now, taking pictures of buildings nearby and scaling up in difficulty to more complex ones and building some general structures like that dog house quickly. Now that I have mostly figured out SketchUp I am moving into 3DS Max where for now I am UV unwrapping the buildings then sending them over to Photoshop, Quixel, and Substance Painter to texture. Only thing is I can’t texture until the models get fixed.

Basically I am setting up and learning my workflow for game design and most of the objects I will be creating will be buildings, vegetation and textures. I also may try to do architectural visualization when I become advanced enough. I’m in school for computer drafting and may learn either Revit or Layout soon which will be pretty sweet, especially when I learn how to model the interiors.

I like to make stuff look pretty :laughing:

Turns out 3ds Max and SketchUp apparently want to kill each other, they said that SketchUp creates “messy geometry” which I know is true as RTCool stated, but I have no clue how to be able to see it in SU or do anything about it.

Then I apparently have to “collapse my stacks and weld my verts” whatever the hell that means I have no clue, basically I have to clean the model because SU threw up all over it. Unfortunately 3ds Max is a pain in the butt to use and learn unless you’re a professional.

It would seem like there would be an easy way to simply export from SU to 3ds Max and not have to go through hell and back cleaning the model which should not need to be done anyways (and I still don’t know how to do).

I found something in a SU forum where someone mentions a “skp. Reader” and from what they said it seems like it is a way to get around all of this mess. I have no clue what this guy is talking about though because I searched all over for it and found nothing.

“for any other accurate/fast manipulation i rather prefer to stay in sketchup… so having the limitation of 3ds format just don’t fit for the needs of the HEAVY model i usually need in that workflow… too much workarounds, exports in chunks, rename things, weld vertices/smooth meshes, fix bad uv mapping and stuff… not my cup of coffee sir… if you find it handy in your workflow use it but i’m in love with .skp reader”

Problem is Autodesk is just saying “Collapse you stack and weld your verts” and all of this other gibberish to someone that has no clue what they’re talking about and not actually helping, as I have learned nothing yet on how to fix it from them. It feels like being thrown into a University grade algebra class while you’re supposed to be in the 5th grade. hopefully they help better explain it…

Hi Easyon,
First of all you must avoid ‘paper thin’ geometry in SketchUp that means you need to thicken walls etc.
Regardless of this it imports quite well into 3Ds Max and as far as i know UV mapping doesn’t create any edge or polygons to your geometry. So there must be a problem with your texturing software i think.

Which software you use? Which file format do you use to import there? Are you sure unwrapping necessary for your step? Will you be painting in 3D model or 2D map?
Note that applying any texture (not color) to a face in SketchUp creates UV map for that face automatically.

Save your model in SketchUp version 8 and import as skp in 3ds max.01

Hi Filibis, thank you for helping.

I the problem is that it imports (only as a V8 file) but when I select the model in 3DS Max and display hidden edges it is a total mess, and Max gives me a “rats nest” error because it is so bad. I will look into the walls but I am still not sure about the bad geometry which they say is the reason of my problems (and they have yet to actually show me how to fix it).

The problem is only noticeable when you either go into Max and right click on the model and go into Object Properties and deselect edges. Or going into the UV and laying out the UV will let you notice, or the texturing process. Just going into Max like roju has above it looks fine, then you UV it or export it and the nasty geometry shows…

I am currently using Quixel which runs in Photoshop, I also have Substance Painter. I tried FBX and OBJ, both of which give the same result as in the picture above.

Oh, and I will be painting all of my models in a 3d software, but regardless, I would imagine if it shows up like that in the 3d texturing software it will also show up in a game which is the end goal for all of my models.

I thought about creating the UV’s in SU but I am not sure if that will fix the issue, I will try, because then at least I think I can bypass max in terms of my models. But again, I would think that Max is just picking up the issue and if I just used SU for the buildings that I need then the texturing software is going to pick it up. That’s my conundrum unfortunately, I got all hyped up thinking I could build my buildings in SU then I hit a brick wall and found out apparently I cant do anything in SU…

But that wouldn’t make sense as I have read of some VFX and game designers using SU, I am truly confused.

This guy makes models for movies and I doubt he makes very complex models using SU and then going through what I am having to do:

Well, what does your model look like if you turn on hidden geometry in SketchUp?

Well that’s something new you say and i don’t get that error. I save as Sketchup 2013 version, that imports to 3ds Max 2017 quite okay. (And i think you shouldn’t worry about that “edges only” in object properties)

Could you please try again after you thicken your walls? That might be the reason…

Hi Anssi,

When I turn hidden geometry on it doesn’t show hidden geometry, but I know it’s there…

@filibis It only displays that error when I export the model from Max to anywhere else.

I am going to have to look into it tomorrow some more and try everything, I am not currently around my PC.

Depends on what you’re exporting as in terms of file format. I used to export as 3ds and what you have would sometimes happen. Switching to skp as mentioned earlier in the thread saved a lot of trouble in the long run.

If you still experience it, I remember I’d have to sometimes add the Edit Poly modifier or convert to editable poly on the imported object to all of the geometries or the selected face for 3dsmax to read as a single face-triangulated faces disappear then for sure.

So I tried some more, even bought the Pro version of SketchUp to see if exporting it as different file types would work (I got the student version). I imported it into Max as a FBX. OBJ. and SKP. and they all gave me the same issue, however this time I exported as SKP and I didn’t have as many polys available for selection in Max in the UV at least.

There are so many possible combinations between export and import I am not sure which one is the magic number and I am just clicking around guessing at this point.

I even used an Extension called Cleanup3 in SketchUp.

I am probably doing it wrong as I am not familiar with Max yet, but when I add a shell to thicken the walls it ends of looking absolutely horrible…I will ask them about that over at Autodesk.

When I go into the UV I see that those two wall as in the pics below have the same marks on the UV when it is flattened and I hover over them. But the UV is merely picking up geometry…

How exactly would I thicken the model walls in SU?

You can actually see where it made that black spot from the right to the left from this picture. I am still not sure as to why it is doing this though.

I know the source of the problem is SketchUp, I just don’t have a clue how to fix it, it is like a massive puzzle. Creating a model in max is fine, but when I create a model in SU no matter how I export it or import it into Max it always comes out the same. I seriously have no idea how anyone could use SU in any workflow if they have these problems, their has to be a simple fix.

Just create a cube in 3Ds Max, you will see those ‘hidden’ edges… So once again do not to worry about that feature in the object properties. (I don’t know when it’s useful to display it and i’ve never needed nor seen anyone enabling it in any workflow)

Can you share your UV islands here and tell exactly how/what you export/import to Quixel (Photoshop)?

Also please try this model and see if it works (Also examine the thickened walls etc.):
Doghouse_v2013.skp (108.3 KB)