Problem with exporting DXF to ironcad

Hello,

At the moment I am busy with a new project and need to export some sketchup files to DXF.
I made all drawing is sketchup schools and so far so good. I removed all surfaces to remove the triangulation problems when using the file in autocad or ironcad (again so far so good). When I export the DXF to autocad all looks good. Dimensions check out etc. However when the same DXF get used in Ironcad, all objects/panels are moved. Originally all lay flay, but in ironcad alle are moved and are upright.

Is anyone familiar with this problem?

Best regards,

Stef Smits

PS: I use the ‘export to DXF’ function. The autocadd add-on gives scaling problems.

So since the same file works fine in AutoCAD, but not IronCAD, it would be safe to assume the problem is with IronCAD. What happens if you open the file in AutoCAD and export a DXF from there to open in IronCAD?

Is it possible you’re missing an import setting?

So it it an X-Y-Z position problem?
“Originally all lay flay, but in ironcad alle are moved and are upright.”

@Sean-WFU

Yess that would probably be the case, also note that I am far from an expert with sketchup (even worse with CAD programs).

IronCAD view:

And the exported DXF from sketchup:
dual18_v1_wireframe_v3_2018.dxf (1.3 MB)

For making this export, I ticked all boxes except ‘Construction geometry’.

@DaveR
Autocad (DXF) --> IronCAD gives the same set of problems. I’ll probably ask this same question on an IronCad based forum. As it indeed seems that the problem occurs in IronCAD.

And here is the AutoCAD view:

Wow, it’s really messed it up. Here’s your dxf in AutoCAD 2020. Looks OK here.

So matching what you see in your Acad. Got to be IronCAD???

Yess, measurements etc are also ok in AutoCAD.

Why dxf and not dwg? Also have you saved in Acad and then open in IronCAD?

DXF was the request from the person that does the cnc work. He also draws some new circles to get it all smoother. Saving in Acad and then opening in IronCAD gave the same set of problems.

If you are exporting as 2D DXF you could export as 3D DXF instead, and then he wouldn’t need to do any smoothing.

If you try that, make sure to turn off Faces in the export options.