Problem with dynamic components not scaling when inserted into model

I have a dynamic component (nested) that scales correctly in the development model but will not scale when inserted in a new model. Have tried turning the scaling attribute off and on in the dynamic component during creation but it does not seem to make any difference. When inserted it appears all the scaling grips are at the axis location for the dynamic component

How are you inserting the component? If you saved the component as a SketchUp file and then use File>Import to insert it into another file, you find it is double wrapped. If that’s the case, you should see it behave as expected if you open the top level component container. You could explode that top level container, too.

And, if that is indeed what you are experiencing, you could avoid that by first saving the component you made via the Components panel and then inserting it into your model through the Components panel instead of using File>Import.

Thanks for the reply. It was created in a separate model and saved using the component panel. Not sure how to insert using the component panel when created in a separate model.

To insert the component into a separate model you would need to open the folder you saved the component into using the Details menu on the right side of the Components panel. Use Open or create a local collection…

Screenshot - 8_1_2020 , 9_25_09 AM

Screenshot - 8_1_2020 , 9_25_53 AM

Then you can drag the component into the model space.

What steps did you take to save it using the Components panel?

Many thanks as this has really helped. Able to insert it and grips work when inserted from a collection. Not sure why this approach works versus the import approach.

Consider that a component is basically a SketchUp model on its own. If you have that component in a model and then save it, then import it you will find it is double wrapped.

Try this to clarify. In a blank file model a simple shape such as a box or cylinder. Do no make a component. Then save it via File>Save. Then start a new file and use File>Import to add that file you just saved. You’ll see it imports as a component with the file name you used when you saved it.

Start over. This time make the shape and create a component before saving the file. Then repeat the new model, import process. You’ll see the component comes in double wrapped.

As I said before, if you do use File>Import with your DCs you could just explode the outer wrapper to get rid of it.

OK. But how does saving it to a collection overcome the double wrapper?

When you drag the component from In Model to the local collection you are saving the component itself as a .skp file. You aren’t saving the component in another .skp file like you are with File>Save.

Got it - many thanks

1 Like

Sorry to bug you but can I use IF-THEN-ELSE logic in a dynamic component attribute setting?

I believe so but that part seems like a thing for @pcmoor as he is our resident Dynamic Component expert.

1 Like

Thanks Dave - much appreciated.

1 Like

= if (condition, then, else)

https://help.sketchup.com/en/sketchup/dynamic-components-logical-f
Capture unction-examples

1 Like