Dynamic Component Creation

components

#1

Dynamic Component Creation (save as) is not working properly. When created in 2018, and inserted into a new model, you have to explode the component, to open the options dialog box. Also, when you open the original model, it is not exploded like usual.


#2

Are you using File>Save as…?


#3

No. Selecting the component and right click save as.


#4

Are you using File>Import to bring it into a different model?

Try this: Open folder containing the DC in the Components window and bring it into the model from there like you should with any components. This will prevent you from getting the extra component container that you get when you use Import.

When you create components, open the secondary pane in the Components window and drag the thumbnail from In Model to the desired collection.


#5

No, I am not importing. I am inserting from the Components Window.

All my 2017 Dynamic Components are working fine, only the ones created in 2018 are not working properly.

I also noticed, when I am working on a component, I need to select the component first, before I open the Component Options dialog. If I don’t select the component first, I cannot access the Component Options.


#6

This is odd behavior which I haven’t seen when creating DCs in SU2018. Out of curiosity, did you install SketchUp 2018 correctly by right clicking on the installer and selecting Run as administrator? If you didn’t, it is not install properly and you can get weird things happening. To make sure that isn’t the cause of your problem, quit SketchUp, find the installer and right click on it. Choose Run as administrator and then the Repair option when it is presented. After that, do you see any change in the behavior?


#7

Running as admin and repairing took care of the problem. Thanks for you time DaveR, I really appreciate it.


#8

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.