Problem updating scene attributes

I’m wondering if anyone else is experiencing a problem with scene attributes updating correctly. It may be a coincidence but it seems to have become an issue after updating to the current version about a week or so ago. My specific situation is as follows: I’ve modeled a cabinet, created scenes for a front elevation, vertical section, plan and an additional front elevation with my door and face frame tags turned off. When creating my scenes, I am setting “toggle section display” and “toggle section fill” as I want them to be and updating my scene. After switching to another scene and back again, SU is not “remembering” the settings as I had selected them.

Any feedback on this is much appreciated. Thanks!

Perhaps you could share the .skp file so we can see what you’ve got.

Section display is a style setting. Are you updating the style to save the change to the section display settings when you update the scene? You should be getting a warning message when you create or update a scene if the style was changed and not updated.

Hi Dave,

Thank you for your response, it led to me figuring out my problem. Somehow I managed to change the style settings for that model without realizing I had. I compared them to some previous models and found the differences. Prior to your response, I was toggling section controls on and off in the toolbar, then updating my scenes, expecting the scene to record the changes. When I would navigate away from that scene and then return, it appeared that my settings were not being saved.

Thanks again!

Glad you got it sorted.

When you change the state of the section display and update the scene you should get a warning message with some options to choose from. That should come up anytime you create or update a scene when you have modified the style without updating it. For example I modified the selected style to Hidden Line face style. The circular arrows on the style thumbnail show the style is modified but not updated.

Before continuing with creating the scene I have to make a decision about the style.

Saving as a new style adds another style to the file. Might be appropriate but if there’s already a matching style it would be better to cancel updating the scene and switch to that style rather than making another one.

Updating the selected style will affect all scenes that use the style.

Do nothing leaves the style un-updated. That’s rarely the right choice. If you did select that at some point though and then ticked the Please don’t show this again box, the onus is on you to keep tight control over the styles in your model. Personally I like that the warning pops up. Fewer problems down the road. If you aren’t getting the warning message and want to turn it on, go into Preferences>General and re-enable the warning.

Thanks again Dave, I guess I had turned that warning message off at some point. I have it reset now.

1 Like

Just be aware that it will have woken a few other warnings too, you can turn them off individually but they all come back together.

1 Like