Updating scene problem

Hello, I have a problem with scene update in Sketchup Pro 2021. I use section plane tool, then axonometric view. I chose view without textures in face styles toolbar. Finally I create scene. When I clikc update scene everything looks ok for now. But when I cklik on scene button Sketchup automatically switches on filling cross-section from section plane tollbar. It is not only on walls. All project is hiden behind dark plane. Aditionally all textures are visable. The same is visable on scene thumbnail. It does not help to set everything up again and update secene. I need that type of view for the leater work in layout. Of course, importing a project into a layout produces the same bad results. Some project works grate but many times I have a described problems.
Thank you for any help.

Difficult to know your exact problem with no image or file uploaded. However, it sounds like it could be to do with the scene style chosen and/or with whether you have section planes visible or not.

As Simon wrote, it would be much easier to help you if you share the .skp file. What you describe sounds like you aren’t updating the style when updating the scene and very likely you’ve turned off the warning that would prompt you to do this. Both the change in section display and the face style change are style settings. If you don’t update the style after making those changes the previous style is still going to be used by the scene.

You should be seeing this message window. If you don’t see it or you are selecting “Do nothing…” you will get what you describe. If you’ve disabled that warning, you should re-enable it in Preferences>General.
Screenshot - 8_12_2021 , 6_49_30 AM

Thank you very much for help.
I made several project these week. I saw this warning window. But not in every project. I think I chose “do nothing”
I uploaded my print screens.

Resetting the all warnings button and selecting “save as a new style” in warning window fixed the problem.
Thank you for help!