Problem purchasing extension from EW

I have tried the extension Eneroth View Memory and decided to buy it. However, the EW informs me that the trial has expired and does not show any way for me to go ahead and purchase it.

I do know that the trial has expired! All I need now is to pay for it.

Any ideas about how to overcome this problem?

If you go to the EW page in your browser and you are signed in, I think you should see a Purchase button instead of the Download button below the large image.

Hi Dave,
I tried it just now and the scenario is exactly the same: no purchase button.
By the way, thanks for the help you have given everyone over the years.

1 Like

Maybe @eneroth3 would have a suggestion.

And you’re quite welcome.

This sounds like a bug in extension warehouse. Generally SketchUp support is the best way to report and get help with extension warehouse licensing errors.

I have just sent them a message. Let’s see what they say. Thanks.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.