Problem logging in again. It seems that every time I go to use Sketchup Pro I am blocked

I went to use Sketchup pro and I am blocked. I don’t want to use it some other time I want to use it NOW. At the prices you charge this should be fixed and fixed now.

We need a better description, what are you seeing that leads you to think SketchUp is being blocked?

Sketchup pro doesn’t block users, if you have problems to login, there must be a problem with your internet connection maybe an add blocker is blocking the website, there have been cases where the router is blocking the sketchup website.

I am using a Mac with a Ventura OS. When I click on the Sketchup icon on the lower part of the screen Sketchup does not come on. I have tried using Launchpad and got the same result.

Have you tried opening a sketchup file to launch sketchup? If it doesn’t work, try uninstalling the software and install it again.

If you Command-click on the icon in the Dock, that will take you to where the original SketchUp application is. Where does it take you to?

There may be a question mark on the icon, which would mean the Dock shortcut has lost track of the original SketchUp application. If that’s the case, switch to Finder, and choose Applications from the Go menu. In Applications check to see if you have a SketchUp 2022 folder (or SketchUp 2023 if that’s what you are using these days). Open the folder and then double-click on SketchUp.

When it opens, a new SketchUp icon will appear in the Dock. You can drag that icon into a preferred position in the left part of the Dock. Drag the icon with the question mark in it away from the Dock, to remove it. After that use the new icon to open SketchUp in the future.

Thank you for your response. I tried Command-click on the icon and it went to Sketchup Applications. No question mark. See attached.
Using Finder, I tried opening a Sketchup file - That worked and I was able to open a new file. When I had tried this before it did not work. The icons at the bottom of the screen still do not work.
I tried uninstalling Sketchup so I could restall it. I found three copies of Sketchup and three copies of Layout. the uninstall did not work - see attached.
I tried going to Finder/Applications and dragging it to Trash. That seems to work. I removed two older copies (2021 and 2023) but I did not remove 2023 as I was unsure how to reinstall it
The icons at the bottom of the screen still do not work.

Screenshot 2023-11-06 at 10.06.57 AM.png

You could remove all SketchUp icons from the Dock, then open SketchUp 2023 from inside its folder in Applications. The icon that appears in the Dock is the one you want to keep.

I deleted all the sketchup and Layout icons and installed the latest program from the application folder. It seems to be working. Thank you for your assistance