Can't login into Sketchup Pro 2022 Mac

Had 2022 Sketchup Pro for Mac trial and it worked fine.
Purchased 2022 Sketchup Pro subscription for Mac and it doesn’t let me log into the application.

What I’ve tried:
-Uninstalling/reinstalling application
-Clear Cookies and Cache
-Updating browser and computer
-Switching from Chrome to Safari
-Logged out of the browser account and logged back in

When I open the application I select login and launch browser to continue logging in. Nothing happens when I click on it.

Then I selected “add classic license” at the bottom. I try to log in via subscription plan and the guy in the upper right hand corner. Nothing happens.

help.

1 Like

@colin are you able to help with this?

Checking into it. Back soon…

1 Like

You did the trial with your own account, then bought the Pro subscription with your company account. That should not matter, the subscription is assigned to your email address.

The button that says Launch Browser Again should never be needed. I imagine it’s there in case you accidentally closed the browser window instead of signing in.

So, the problem you’re having is that your system isn’t letting SketchUp open a browser. The address that is attempted to open is http://127.0.0.1:62472 (where those last numbers will be different for you). In some cases that IP address can be interpreted as being an Intranet address, and the system security settings may treat that in a special way.

Do you know of any security settings that could be affecting things?

I am not expert on such settings, I’m hoping that if you do have some security software installed that could be affecting things, that you will know what to change.

The trial version of SketchUp is the full program, it’s identical to the paid for versions. If you’re on the same computer, and the same network, any problems you’re seeing now should have happened during the trial period.

BTW, the Classic license tab isn’t involved at all.

Hey, after typing all of that I thought of one thing worth trying. In Finder’s Go menu is Go to Folder… Select that and paste in this text:

~/Library/Application Support/SketchUp 2022/login_session.dat

Delete the file that you are taken to, and then open SketchUp again.

The browser was open when I attempted to sign in to the application.

I have no security software and I’ve given accessibility to sketchup under “security + privacy”.

I am on the same computer, that’s why I’m like WTH!?

Nothing with that file name in my computer.

Still no luck :frowning:

That file is in a support folder. Searching for its name in Finder won’t show any results, you would need to get to it either in the way I said, or you can go a longer way to get to it:

  1. Hold down the Option key, and choose the Go menu in Finder.
  2. Select Library. You can release the Option key after that.
  3. Go into the Application Support folder, then into the SketchUp 2022 folder.

login_session.dat should be there.

If this doesn’t solve things I would ask someone in support to contact you, and do a screen share session to try any other ideas they can think of.

Something you can do as a useful test, but also to keep you going for the moment, would be to install SketchUp 2021. Your sign in will work for that version too, provided SketchUp succeeds in opening a browser window. Here is the Mac disk image for SketchUp 2021. You don’t have to remove 2022 to try the idea.

https://www.sketchup.com/sketchup/2021/SketchUpPro-dmg

This may be helpful… There is no Sketchup 2022 folder under application support… see image.

I’ll try and download 2021 now too :slight_smile:

THANK YOU

You are showing the way to the root Library folder. That’s a different folder to the Library that is in your user folder.

The Option key, click on Go menu, shows the right Library folder. Try the same steps by going to that Library folder.

Yep - I’m dealing with the exact same issue and have tried deleting the root login file, and deleting and reinstalling the app. It seems like there is an issue with it not popping up a login window, but I can’t find what would be stopping it…

Could you try 2021 as well, see if that works?

Well… I tried 2021 and it started up with a Welcome Window that did allow a pop-up to a browser to log in - and was able to login, so it seemed to work fine. I do recall the 2022 version doing that (opening with welcome window) the first time it was installed, maybe a month ago. It did not do that on the reinstall.

One other note if I try to open a file in 2022 it pops up a “Auth token cannot be used. The user must sign in” box…

Found a hack around it… in SU 2022, Sketchup/Preferences/General - I clicked “Show Welcome Window” This opened the welcome window and when I restarted it popped up and magically had me logged in to SU and allowed me to open existing files.

1 Like


Login_session.dat is showing in that folder.

Delete 2022 and downloaded 2021, no problems. very odd.

I may not have any more ideas this evening, but I did email the most senior support engineer, and asked him to come and read what we have been trying. He is unlikely to read my email tonight, so I will check in with him in the morning.

1 Like

I’ve had a few of these appear over the weekend too, I’ll be keen to hear any workarounds you’ve found.

We’ve had one end user report that deleting the login_session.dat file worked for them, and they’re using 2022 fine after this browser launch issue. We currently waiting to hear back from a few more trying this.

2 Likes

Hello, I have the same problem as OP now :confused:
Before I had this problem today I was using SketchUp 2022 with no login issue for months now.

The last things I did before this happened were the following…,.

  • Render scene with Vray 5
  • Re-install Plugin-Store for SketchUcation because Fredo6 plugins prompt me to. I removed it from the Plugins folder just in case but the same problem keeps happening.

Also, I have SketchUp Pro 2017, and SketchUp Pro 2020 Installed and they are still working. The only one with a problem is 2022.

I tried re-installing SketchUp Pro 2022 but nothing changed.

Here is a screen of my login_session.dat

Document has 518 lines of encoded text.

Ok before posting I did not read this. But, I deleted the login_session.dat and SketchUp Pro 2022 allowed me to sign back in. Thanks!

I am also experiencing a “cannot open” issue for SU 2022 subscription on a new MacBook Pro. Everything worked until this week and then - see the attached screen shot. I have rebooted, quit, removed, reinstalled, etc… - no luck.

Try signing out via the help menu:
[menu] Help > Signout (emailaddress)
Then quit SketchUp
[menu] SketchUp > Quit SketchUp
See if that works.