SketchUp Pro 2022 licensing "launch browser again" and nothing happens

Hi,
I’ve been working this last month with my new Sketchup pro online license without a problem and now it stopped working.
The welcome to Sketchup menu opens and it appears a box to “launch the Browser” but this Button doesn’t launch it.

There is no going further right now. I’ve tried to do the login online - everything is normal - but nothing changes.

I would apreciate your help because I need urgently to keep working… THANKS!

You can go to C:\Users\your-user-name\AppData\Roaming\SketchUp\SketchUp 2022\SketchUp, delete “login_session.dat”, then try again.

Kinda same here… Sketchup2017, SketchupPRO2021

So yesterday had this with my sketchup2017FREE/MAKE, and today with our SketchupPRO2021:

Started sketchup, all fine…using sketchup, all fine…closed file,… no problem…, started a new drawing, all fine… add geo location, need to login! (ehm, i’m already logged in and using pro?)… trimble: cant find login page (after using the link provided in the mesage)… trimble: no clue what you want to do (again after i clicked the signin link), then page not found (argh o.0) … finally logged in … new attempt add geo location … you need to login (BoOoM!!? head exploded, lol)… logged out (o.0), logged in (0.o)… another attempt to ad geo location… yes, succes! (spend 20 minutes for 30 seconds of work to ad a geo location o.0)

updated message:
After reading that there are problems that are now being worked on, I have nuanced the message a bit :wink:

Hi,

I am not able to find that folder on my iMac

This would be the file on Mac. You can go to Finder, Go menu, Go to Folder… and paste in this text to get there:

~/Library/Application Support/SketchUp 2022/login_session.dat
1 Like

Dear Colin,

It worked!
Thank you so much :smiley:

I met the same problem, but I can’t find the folder you said,please!!how to slove it ><

Did you follow my steps?

yes,I can’t find the folder :persevere:

When you did the copy and paste, did you include the ~ character? You could try going to the folder instead of the file, by pasting in this text:

~/Library/Application Support/SketchUp 2022/

If you don’t see login_session.dat in that folder, I’m not sure what is going wrong.

Do you still have 2021 installed, and can you try it to see if it works?

:bulb: Maybe it is not installed but runs from dmg? (I’m not on Mac, just an idea… )

but I can still login last week :sob:

There is something that broke recently on our side. Deleting that file was a hopeful fix, though I know it hasn’t worked for some people.

A support colleague helped solve the problem for a Windows customer, by renaming the AppData folder. Things are different on Mac, but you could test something similar. But, it does rely on you being able to find your way to ~/Library/Application Support/. If you cannot find that folder it wouldn’t be possible to try the idea.

don’t mix up with the public folder, you cannot simply browse with the Finder to the library folder (which is hidden by default), do use the “Go > Go to Folder” instead.

Being in the Finder you can also press the Option key to get the “Library” folder to be shown in the “Go” menu.

I am also on a Mac. Found the login_session.dat for '18, '19, '21 and '22. Deleted them all and emptied the trash. It still will not launch the browser to get my credentials. I have the professional version by the way.

Carrie

Try deleting the webcache folder , as well.
Be sure to have no apps running that relate to SketchUp (LayOut/StyleBuilder)

Did that too.

I’m in the middle of a build and can’t get to my design. :-/

Carrie

Hello,
Sorry to bother,

I’m using windows 11 and have same problem and i tried using this info. In AppData\Roaming there is nothing, so i think login_session.dat is solved, but my computer still cant launch sketchup app, and nothing working. I really need this app to launch, i had a lot of works to finish.

I would apreciate for help…
Thank you

p.s. sorry for bad grammar, i’m from Indonesia, and English is not my common language.

AppData is an invisible folder, you may not have found your way to the right place. If you are using SketchUp 2022, copy this text and paste it into the location field in File Explorer:

%AppData%\SketchUp\SketchUp 2022\SketchUp

You should then see login_session.dat. If you have file extensions hidden it would look like it’s named login_session

attached Windows batch scripts for deleting the “login_session.dat” file of the latest SketchUp versions 2019-2022 by simply running/executing the according script.

If you don’t trust you can peek in the content of the batch file (text format) with every plain text editor.

DELete SketchUp Pro Authorization Status File.bat.zip (1.4 KB)