Can no longer log into Sketchup Pro 2022 - browser won't open

Just installed SU2023. Decided that I need to wait for some things to get fixed to use it for work. Deauthorized all devices. Tried to run SU2022, and I get the standard “complete the sign in process in your browser”

Except the browser (using MS Edge in Windows 11, don’t have another browser installed) won’t open the login page no matter what I do.

I even tried deleting the WebCache folder to no avail.

Please advise. Can’t use sketchup pro for work now.

EDIT - uninstalled SU2023, rebooted, am able to use SU2022 (open & save files).

Out of curiosity, when you installed SketchUp 2023, did you do it correctly by right clicking on the downloaded installer and selecting Run as administrator?

Yes. That’s how I installed it.

In File Explorer under your username go to AppData/Roaming/SketchUp/SketchUp 2023/SketchUp and delete the file called login_session.dat. AppData is a normally hidden file but you can make it visible in File Explorer. Then install SketchUp 2023 using the right click and Run as Administrator method. Make sure you have the latest installer from See if that helps you getback to working in SU2023.

Thank you for the followup.

That file doesn’t seem to exist in the directory you mentioned. However, my goal was to get back to 2022 since there were some things that no longer work (Eneroth Viewport Resizer) in 2023. I am happily back in 2022 right now.

You should have been able to just use SU2022 without removing 2023.

In case you had looked in the wrong folder, paste this into File Explorer should get you to the right one:

%AppData%\SketchUp\SketchUp 2023\

I fixed your extensions issues, and they should work in 2023 now.

I agree, I should have. I don’t know if it can be correlated, but while I had 2023 installed, I was unable to run 2022. I was getting the screen where it would tell me to log in at the browser…which wouldn’t open.

Once I uninstalled 2023 and rebooted, 2022 stopped giving me the “log into the browser” and worked fine.

Thank you! That appears to have fixed my extension issues in 2022 as well. Much appreciated!