Login window not opening when I click Login in SU App!

Hi All,

I just brought the 2022 SU Pro subscription. When I open the app and click ‘login’ the window to type in my details does not open (I did not have this issue before setting up this new subscription).

I have tried clearing my Cache and Cookies and all that stuff, unistalling and reinstalling etc. nothing has worked.

Also my Login details are fine as I can log into my account online totally fine.

Anyone know what may be going on?

What operating system? You put ‘2022’ for that in your profile which doesn’t answer the question.

I’m getting exactly the same issues.
Cannot get past the software launch window that asks me to sign in (when I already am?)
The launch browser again option button also does not respond.
I am completely stuck at this point.
I have restarted, uninstalled, reinstalled, used various browsers etc etc
I run windows 11… have had no problems till today.
Spent hours stuck here :-/

Whoops - I am running Mac OS Monterey

Yes, that sounds exactly the same as me - Also tried on another iMac desktop - same issue.

No solution - Can anyone help?

What MacOS are you on currently? if you go to the apple logo in the top right and choose “about this mac” it will tell you

12.01, 12.1, 12.3 etc

Try deleting your login_session.dat file

 For Mac users, locate the login_session.dat file in your Library folder. (The path for this file should be Library/ApplicationSupport/SketchUp[Version Year]/login_session.dat)

If you don’t know how to find the “library” folder. You can find instructions here: How to Reveal the Library Folder in macOS - MacRumors

 For Windows users the file is located in C:\Users\*USERNAME*\AppData\Roaming\SketchUp\SketchUp VERSION\SketchUp

You can quickly get to the folder s by pasting %appdata%/sketchup/sketchup 2022/SketchUp into a file explorer address bar

Just purchased and having the same issue, cannot login or access program

I am having the same issue. I click the “Sign In” button within the SketchUp app, which sends me to a web page for me to login, but I don’t see any fields for logging in, hence rendering me stuck.

Is there any solution to this problem??? I need access to my current subscription so I can draw a critical project.

And, by the way, this is what I’m seeing. This is occurring both on Safari and Chrome. I am running macOS 12.3.


Again, there is no login fields present, no matter how many times I click the “Sign In” button. It shows this same screen again and again, hence making the software unusable. Again: Please advise on what to do to remedy this recurring problem.