Problem Installing SketchUp Viewer in Hololens

I’m attempting to install the SketchUp Viewer for the first time on the HoloLens and it keeps telling me:

  1. This product needs to be installed on your internal hard drive.

  2. See System Requirements, this product needs hardware your device doesn’t have.

Can anyone please help me, I’m not sure what I’m missing this is preventing me from installing the app.


I have the same issue, I contacted the helpdesk and they told me to update the hololens. Unfortunately i already had so this was no solution, I’m still waiting for a new reply.
Please let me know if you make any progress

Good Morning Tom,

I actually did have success yesterday!

I uninstalled and reinstalled SketchUp Pro 2019 – trial version and the SketchUp Viewer on my desktop. Miraculously, after doing these two steps, I was able to install the AR/ VR Extension directly
in SketchUp (this was not previously available either).

Once this was complete, I turned on the Hololens and the SketchUp Viewer was now available for install as well. Successfully installed this and launched the Trimble Connect from my desktop and I
was up and running.

The only factors I can contribute my earlier frustrations to could be a bad install of SketchUp and potentially a bad Wifi connection.

Try starting fresh and let me know if you have some success. Good luck!


Thanks a lot for your reply, it worked!

I did need an additional step as the install button remained greyed out for me, but by attempting to ‘remotely’ install it to another device connected to the same Microsoft account (from
within the hololens), the hololens I was using appeared in that list and I was able to install it that way.

I’m still confused as to how running the software on a laptop in the same wifi network seems to be required to install the viewer app on the hololens. Nevertheless I got it to work,


Verzonden: dinsdag 5 maart 2019 16:36

Glad to hear it Tom! And I agree, there was really no definitive rhyme or reason to it, I was just glad that it finally started working.

I am finding that the files size (.skp) for a successful demo is quite modest at only 18 MB…

Have you been able to load larger files and avoid crashing when toggling through the features within the app? Just wondering if this is a know drawback for the SketchUp Viewer or if it is a limitation
with the Hololens. I struggle with the latter, as I’ve seen the Hololens do some pretty amazing things with a more sophisticated demo.

Thanks Tom, appreciate your feedback.

Talk soon.

Hi Michelle,

I have had some time to experiment and also experienced crashes with larger models. I’m currently investigating using Unity for more complex models. It should be possible to use the
processing power of your PC for rendering so the hololens only functions as a display. The hololens app for this is called holographic remoting.

Kind regards.


Verzonden: woensdag 6 maart 2019 16:27

Hi Tom,

I’m having a similar issue where the install button is greyed out. Also, I cannot seem to install ‘remotely’ as the hololens does not appear in the list of the other devices.
Have you any ideas on what i could do?


Hi Macabi,

I have no logic as to why my approach works, but here’s what I did:

make sure the HoloLens has all the recent updates, then connect your laptop and HoloLens to the same wifi network, make sure sketchup is running on your laptop, then next to the install button via the three dots the option of remote install allowed me to select the HoloLens. Although out of the three hololenses i tried, one of them refuses this approach, and i have not yet been able to determine why unfortunately…

Hope this helps!

This topic was automatically closed after 183 days. New replies are no longer allowed.