Problem importing models with quads

Hi!
I’ve been recently struggling to import OBJ models from Blender do SU with quad topology. Certainly I’m using QuadFace Tools importer but all meshes only display as triangles. I’m sure the model was exported properly with quads cuz another program could read them, yet SketchUp couldn’t. Folks say that imported model should be automatically displayed with quads, so: hard edges in loops and soft edges in diagonals. In my case all edges are soft and even “Convert Blender quads to QuadFace quads” button does nothing.

I attach the OBJ model here:

I know, the plugin has its thread on SketchUcation but I didn’t receive any answer there so I thought, I’ll try to find help here.

Aha, if anyone has access to full documentation on QuadFace Tools, I’d be grateful for sharing. The one on BitBucket is no longer available and the one from GitHub is quite cursory.

You could thus ‘transform’ your model, but …

… the selection goes well and without doing that ‘transformation’.

1 Like

I see! I have to Unsmooth selected quads and then I can see hard edges.
I wasn’t aware that quads were already there.
Thank you!

You could use the CleanUp 3 plugin and choose in the options to delete coplanar edges. That would get rid of the ‘soft’ diagonals, which are in the plane of the quad.

Sure but actually I just wanted to see “loops” and “diagonals” distinguished :slight_smile: