Issues importing obj and stl files

I am trying to import an Shapr3d OBJ file into sketchup and when i set to import in inches, it does import the file but a lot of faces are missing. Then i switched it to feet and i get an error: quadface tool error report window. i also tried the rest of the other measurement units and it doesn’t work either.
Before I was importing them as STL but that type of file was making the whole entire file too heavy causing sketchup to crash and it was making the vray take forever to make just one rendering.
What am i doing wrong?

Try to import OBJ with this extension: Universal Importer

1 Like

thank you for suggesting this plugin, i went and tested it but it’s still not working.
when i import the object it already comes with missing faces and then when i used the plugin it makes it worse. maybe the question is why the object is missing faces?? if it was in perfect conditions when it was exported from 3dshapr ??
when i exported them as an stl file all the faces were there. Do you think is something i am doing wrong at the moment of exporting it ?? :woozy_face:

You’re welcome!

Either those faces are missing from the OBJ file (less likely), or the model is on too small a scale and happens to lose faces once imported into SketchUp. Check both possibilities.

You could also try the Skimp and Transmutr importers, which have a good (visual) control over the imported objects (before inserting them into the SketchUp model).