Problem exporting to DXF

Hey, first-time poster! Any help greatly appreciated

I’m trying to export my models to DXF so I can have them cut by CNC. When I export to DXF the scale gets totally skewed and comes out over 25 times bigger.
for reference - a length that should be 1469mm is coming out as 37317mm in the DXF file.

I’ve followed all the procedures I have read about -

-Top View
-Parallel Projection
-Zoom Extents
-Hidden Line
-Export 2D > DXF Format > Scale 1:1 etc…

I’ve also tried 3D Export, same problem.

I’m sure I’m doing something stupid,

I have to get these files out to the CNC workshop tonight, any help greatly appreciated,

Sketchup model attached below.

OS4 .skp (434.0 KB)

37317 / 1469 = 25.4
The DXF is probably exporting as if 1469 is inches. So look at your units on the export/import options.

SketchUp always exports using the units that are used in your model. Check your modelling units (Window menu>ModelInfo>Units). If you aren’t inadvertently using inches instead of millimeters, the error is probably in your receiving application which is interpreting your import file as using inches. Check your import parameters. If the application MUST have inches, you can switch your SketchUp units to inches before exporting, and switch them back afterwards.

Thanks so much guys! Problem solved, I started to design in inches and then changed to mm, I didn’t realise I’d have to change the units back to inches for it to export properly!

Many thanks,… Life savers.

So essentially, your model is 25.4 times larger than it should be. You can rescale your entire model with the tape measure tool: https://www.youtube.com/watch?v=eXh6y5b0pdg

No it isn’t, but the CNC application he uses apparently doesn’t understand millimeters and needs a file that is in inches.