Problem accessing my EDU subscription

education

#1

i bought a sketch up pro the student one year license on March 10, i received the confirmation of the payment and the order confirmation. I submitted proof of being a student. then the next day i received two emails the first email stating ‘’ You have been assigned a license to SKP-EDUSTU-YR by orders@creationengine.com from Trimble.

Please check with , orders@creationengine.com for license usage guidelines.

To view all the licenses assigned to you, please visit [account management portal]
Thank you,
The Trimble EPP Team’’

The second email stated ‘’ Your order was successfully provisioned and is now available for you to use. Your order number is 985662

Product Quantity
SKP-EDUSTU-YR 1

To access your subscription, please [click here]
Thank you for your purchase,

Trimble Inc.’’

When i try accessing the license information so that i can enter it in sketch up, it only tells e about my free trial; which by the way has ended and now sketch up wont allow me to do anything it keeps on prompting me to purchase the license which i already have. The second email that was sent has a whole new order number different from when i first purchased it. please help i have finals and i need the license ASAP!!! THIS IS JUST RIDICULOS AND THE FACT THAT YOU GUYS DO NOT HAVE A CONTACT CENTER FOR PEOPLE TO REACH OUT FOR SUPPORT IN SITUATIONS LIKE THIS IS JUST UGGGGHHHH!!!


Haven't received the license info
#2

Did you bought directly from Trimble, or via a reseller?
In the Account Management Portal, go to the Member tab and add yourself as member.


#3

I purchased it directly from Trimble


#4

@MikeWayzovski i purchased it directly from trimble


#5

This is not a chatbox :smiley:

AMP

Help


#6

I asked because if you bought through a third party, you will see more then one Plan and Member area in the AMP.


#7

@MikeWayzovski
the URL of the AMP is personalized, better use: Trimble Account Management Portal


#8

@MikeWayzovski where can i access the account management portal ?


Haven't received the license info
#9

@Djenipher99 did you succeed?


#10

@MikeWayzovski it’s not allowing me to add myself as a member and no i did not succeed, so trimble is considered a third party? what can i do about this is there any other way


#11

Try to log out in SketchUp and back in
@ChrisDizon


#12

@MikeWayzovski i have already tried that and nothing i have even tried uninstalling and reinstalling sketch on my computer and still nothing


#13

@Djenipher99

Did you sign into the SketchUp application with the same email that you purchased with? Since you are a student, I would assume that the subscription was assigned to your EDU email address

Can you upload a screenshot of the AMP > Members area? Feel free to redact your email in the graphic.

Also, be aware that you purchased the Subscription through our educational reseller Creation Engine. Note: "orders@creationengine.com"


#14

@ChrisDizon Yeah i tried that and it worked. i fine it odd because i never created an account with my school email although i did use it to purchase the student license


#15

This could be related to your other warehouse issues.