PRO 2018 License & Errors

Hello, I am having a couple of issues with my Sketchup Pro 2018 software on a new computer. My previous computer failed and I had to buy a new one. On the new one Sketchup 2018 Pro will not work, nor will it validate my license:

Error #1: “Bummer, You’re offline - You must be online to add or remove Sketchup Licenses”

Error #2: Invalid License

Sketchup Pro 2018 License starts with: TA-

Computer Specs:
Apple MacBook Pro (13-inch, M1, 2020)
Big Sur 11.4
Internet connection: FiOs Gigabit

The first error is concerning because I am indeed online, and have no issues posting here, surfing the web, or using other software requiring an internet connection.

For the second error, I’ve already gone through the process of removing the license from my old computer.

Thank you for any insight. I’m not getting any help from support.

Make sure SketchUp is closed. Go to Finder, and from the Go menu, choose Go to Folder…

Copy and paste in this text, then click Go:

/Applications/SketchUp 2018/SketchUp.app/Contents/Resources/Content/Resources/en-US/i18n.dat

The file that gets selected includes a value that is used for when checking to see if you are online or not. The old URL that was put into SketchUp 2018 seems to be failing for some people. A solution that has worked for several people is to edit the URL to be something else.

The file can be opened with TextEdit, you can do that by dragging the file on to TextEdit’s icon in the Dock. When the file is open, look for these lines:

[ONLINE CHECK]
ONLINE_TEST_URL=http://www.google.com/ncr

Change the second line. Later versions of SketchUp used bing.com, so try making those two lines be like this:

[ONLINE CHECK]
ONLINE_TEST_URL=https://www.bing.com

Save that and close the document, then open SketchUp again.

Later operating systems tend to object to you trying to access an insecure web site, and the address that starts with ‘http’, which was perfectly good 3-4 years, can now trigger a security warning. By making it be ‘https’, that should keep the system happy.

Please let me know how that goes.

4 Likes

colin, this was incredibly helpful and seems to have worked. Thank you very kindly.

wow! you are my hero, my problem is solved with your solution

Colin, Wow, my connection to the Extension and 3DModel warehouse has been broken for a long time. I got tired of workarounds and found your post when looking for a solution. The steps you provided are simple to follow and solved this problem for me. Yoo-hoo, so simple and now it’s fixed! Thanks a ton.

Hi Colin,
Do you have a similar solution for a window environment?
I am working on windows 10 and I have the same message: bummer… you re offline.
Can you help me?

The same fix works for Windows too. Here is my full post, which includes the Windows details:

Thanks for your quick and useful reply!

Hi Colin! there I also helped you. Thank you so much!! I changed this issue to change to Windows 11 laptop.

Windows11 case;
C:\Program Files\SketchUp\SketchUp 2018\Resources\en-US\i18n.dat

The contents of this were rewritten.
[ONLINE CHECK]
ONLINE_TEST_URL=https://www.bing.com

I live in Shanghai Now.

I have changed the line in a text editor on mine and fixed the first issue. I’m now getting an “invalid license” error. I’ve removed SU2018 from my previous computer, but my serial number and authorization code are not working. Does anyone have any ideas?