Printing problems with SketchUp Make

advice

#1

Hi
I am new to SketchUp, but am really enjoying how easy it is to use.
I have designed one house and learned a lot (especially how not to do some things!)
Decided to save as so I could delete some layers and make better thosed bits I **** up.
The improvements are good (I am very objective) but I have developed a problem with printing (pdf and canon printer) which I did not have with my first attempt.
The printed picture is very small and includes what looks like the sky (above the horizon) on the model which takes up the whole width of the print (including preview)
When I print some layers separately, the sky does not feature and the print is full size (fits the page).
Anyone know what I might be doing wrong. Any help would be appreciated
Thanks to all
Alan:


#2

Most likely you just need to zoom in on the model. When you print directly from SketchUp, it uses the full size of the model window. If you want the model to fill the page, fill the model window with it.


#3

Hi Dave
Thanks for responding. Have tried thatnew house roof.pdf (243.7 KB)
new house sun room.pdf (54.9 KB)
The attached pdf’s show my problem. The sun room shows what I get when printing a perspective view and the roof shows what I get from a plan view (both instances the model fills the whole screen). The perspective appears to include the sky which is much bigger on screen than the model.
I need to show my builder drawings of each level so he understands the building packages I want
pleased if you could put on your thinking cap again
regards
Alan


#4

How about sharing the SketchUp file so I can take a look at that. From your second PDF, it looks like if you did use Zoom Extents, there must be some stray geometry ofr something. Seeing the SKP file will help to make it all clear.


#5

Dear Dave

Thanks for the reply.

Tried emailing the drawing file to you, then my MS Outlook hung up. I should have checked the drawing file size first, it is 90Mb, so something was wrong

However, created a new drawing copying each layer from the old one and service is back to normal!

It may be that some of the 3D library models came with large files, so I will resist using them

So I am OK now, and thanks again for your offer

Kind regards

Alan


#6

A couple of things for you, Alan.

First, in your new model, go to Window>Preferences>Statitistics and click Purge Unused. That may help with the file size.

B. Very likely one or more of the 3D Warehouse elements you added to your model have some extraneous bit of geometry located at a distance from the rest of it. That would account for Zoom Extents zooming out instead of in on your house. You can check for that sort of thing by selecting components one at a time and checking to see if their bounding boxes make sense. If the box is considerably larger than the apparent component, there’s some geometry causing that. Here’s an example I set up just now. I added a tiny short edge segment off away from the rest of the geometry for the panel component. It’s included in the component and in the far left corner.

Note that it isn’t even visible in the model space.

Zoom Extents makes the model appear like so:

This is because both wood panels are instances of the same component.

So if I was to print that with Use Model Extents selected, it would appear that it isn’t filling the page correctly. Actually, for the model extents it would be filling the page but it wouldn’t look like it what you expect.


#7

Dear Dave

Tried the “purge” option and reduced the file size by 50Mb. I might look at the size of the 3D models as I expect that is where the big file sixes are.

However, I have copied over to a new file all that I need to show my builder what I need him to do

I haven’t worried about total accuracy as I just need a pictorial way to explain the various packages. My MicroStation CAD provides the fine detail.

I am happy with my first attempt and attach the drawing file as an example of a novice

Thanks for your help

Regards

Alan

(Attachment final copy.skb is missing)


#8

A 50 Mb drop is a pretty good one. Especially when the file started out at 90 Mb, a 55% reduction is helpful.

When using components from the 3D Warehouse, it’s always advisable to import those into a separate SketchUp session so you can examine them for weird or unneeded stuff and clean them up before you add them to your main model. One bad apple can spoil the barrel.

Glad you got it back to working and were able to show the builder.