Printer info missing from print window


Everything was working fine until my PC decided to hose up the printer driver. I had to uninstall and reinstall the HP driver but now I get a different HP configuration window for printing (I suppose it’s not the same driver I had.) and nothing appears in the SU printer preview or print window. Rebooted, restarted and rebooted again.

Anyone else have their info just disappear? I tried to print to PDF but without the scale and other attributes it’s just all on one page.

I printed this template before all this happened and it’s in use (already on a wood work piece so no reusing it and at the moment I can’t use that piece as a model, long story). I just wanted to print another template and use it.



To what do you have the printer set at the top of the Print or Print Preview winodw? Try changing it and then change it back to your printer.

I tried that and it still gives blanks in all the fields. Prior to this I had been switching back and forth to use the PDF and it populated the fields. This time it’s blank.

Short of uninstalling but that’s drastic…

Does anything change if you tick the Fit to page and Use model extents? Try that in Print Preview and then click OK. Close the window and try again.

Nothing changes. I have clicked on every field, open and closed. I think this driver is not happy with SU or vise versa. I may have to go to another computer to see if I get the same reaction. They pull up the same printer manager window so if I get the same thing then it’s SU not liking the printer configuration or can’t find it to load it into SU. Theorizing and reaching right now…

Good luck with it. I suppose it could be that SketchUp 2017 isn’t happy with the current printer drivers. Of course there won’t be any changes to SketchUp 2017 at this stage so hopefully you can sort it from the printer end.

I agree. When windows decided to trash the printer I didn’t have a choice but to uninstall and reinstall. Unfortunately, this driver is not being recognized by SU.

thank you.

1 Like

It’s been a problem with newer SU versions too. Some printer drivers don’t play well. Microsoft PDF printer driver, if I remember right, is one of these too.