Print to scale (1:1)

sketchup
print
printscale
printing
scaleprint

#1

It seems that with SketchUp 2017 (NOT the PRO version; Not Layout) it is no longer possible to print to scale. The Print dialog used to come up with the Page Size all filled in and I just filled in the Scale. Now it comes up with nothing filled in anywhere. Not even Fit to Page works any more. If this is no longer possible, can I revert to a previous version?


#2

There should be the option to set a scale and print to 1:1 with SU2017. Did you install SketchUp correctly? That is, when you installed it, did you right click on the installer and choose Run as administrator?


#3

No. I left double-clicked on the installer. It has been a while since I did the installation, but I seem to recall that then a window opened up asking for administrator authority. Since I am the only user and therefore the administrator of this system, I only had to click it and the installation proceeded.


#4

Then SketchUp is not installed correctly and may be the source of the problem. See:


#5

So do I need to delete it and reinstall, or can I re-install over the top of it.


#6

You should be able to do a repair after right clicking on the installer and selecting Run as administrator now.


#7

I’ll give it a try. Thanks.


#8

Good luck. After you do that, make sure your graphics drivers are up to date.


#9

First I did a repair by right clicking and choosing Run as Administrator, but I got the same results. Then I deleted Sketchup from my computer and reinstalled it, also by right clicking and selecting Run as Administrator. It still behaves just as it did before. I still can’t figure out what to put in the print dialog which now comes up completely blank. It also has no units in the drop down boxes so I typed in “inches”.


#10

Can you share a screen shot of the Print or Print Preview window?


#11

I made a photo of the Print Preview Dialog using MWSnap, but I can’t see how to attach it here.


#13

7th button from the left above the space where you type the text of your message. It’s just to the left of < / >.


#14


#15

Isn’t print scaling only available when your camera is in Parallel Projection?

Camera --> Parallel Projection


#16

Print scaling is only available if the Camera is set to Parallel Projection but the various fields in the Print or Print Preview window should still have values even if the camera is set to Perspective. Scale will be grayed out.

@casaerwin0135, do you get anything different if you change the printer? I don’t have a printer mapped to this computer but I get numbers with the XPS Document Writer that work as if I did have a printer.


#17

No. Whichever printer I choose, the dialog box looks the same. And my camera is indeed set to parallel projection.


#18

There are some other reports of this sort of thing. One solution that worked was to make sure printer drivers are up to date. Another reported another thing that worked here:

It isn’t specific to SU2017 and it seems to happen with older printers.


#19

I bought this printer about 5 months ago just about a month before I installed SU2017. I can print my Sketchup file. I just can’t get it to print to scale. That article gave me an idea. I changed my printer in Print Setup and then brought up the print dialog box and the values were indeed filled in like they should have been. Then I changed the printer back to the one it needs to be in the print dialog box and set my scale. It printed just fine. I still think the problem is with SU2017. SU2016 worked just fine.


#20

It would still be worth checking to see if there’s a newer driver for the printer.


#21

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.