Print 2d sketchup tiled

Hi my friends!!!

I have this file attached final.skp (140.6 KB)

I want to print a 2D view of the plane green X red. I want skecthip to print this 2d view in A4 paper tiled! So I can print it and glue the pages together.

I cant find a way to do this… even using LAYOUT I cant do this cause when I start LAYOUT it says to me to choose a paper size so I cant draw a bigger object than the paper and have it tiled later automatically.

You can do this in LayOut. If you use Send to LayOut from SketchUp, go ahead and choose a template. Then after the viewport is displayed on the page, go to File>Document Setup>Paper and set a larger paper size. Then you can drag the edges of the viewport to resize it and set the scale in the SketchUp Model inspector window.

To set a scale you’ll need to set the camera to Parallel Projection and select the top view.

After you have it set up the way you want, export a PDF and use Acrobat or Adobe Reader’s poster print option.

I would draw some non-printing lines on the paper in LO to show where the edges of the A4 paper would fall. That would help to keep important details out of the overlap areas.

@DaveR THANKS! I did what you said and used SEND TO LAYOUT. But when layout opens I need to select a paper, ok, I selectd A4. So Layout scaled my model to fit inside the A4 paper but my model is 10x biger than A4 paper. Even increasing the paper size it does not scale my drawing…

Also, do I need to set PARALLEL PROJECTIO in skecthip before clicking SEND TO LAYOUT?

Did you read what I wrote?

Yes. Set the camera to Parallel Projection and select the top view.

Select any paper size to start. It doesn’t matter. After the viewport is displayed, change the paper size and resize the viewport. I managed to get your shape to fit on A1 paper at 1:1.

You could also open LayOut first and select the papr size from Document Setup. Then use File>Insert to insert the SketchUp file.

Thanks, I did that! BUT I had to manually scale the model “on eye”. How can I make sure the end size of the model is exactly the size it was in sekcthip?

I did exactly what you said. I ended up with this below. How can I make sure the size is correct? Also, in your printscreen it does not show up this gray rectangle that mine is shoing, how to remove it and only show the outlines of the drawing?

If I right click the model -> SCALE-> FULL SIZE then the model disappears!

You didn’t do exactly what I said. Select the viewport. Then open the SketchUp Model window over in the tray on the right and set the scale to 1:1.

worked!!! But why my print shows a gray background? When I print this it will use too much tint. How did you make the model appear with transparent background and only the outlines are shown?

See my print below, you will see a huge gray area is appearing:

Yours shows the gray background because that’s in the style you are using in SU. Change the style to one with a white background or edit the existing style. Then save the file and update the reference in LayOut.

Great!! Now the most important part: generating the PDF. I am using A1 paper size. How do I generate the A4 paper size tiles?

I generted a PDF, see it attached. NOthing is appearing inside.aa.pdf (3.7 KB)

File>Export PDF. Then print the PDF. Go to the print settings in the PDF reader and set it to Poster printing.

I did what you said! The file is below. There is some weird problem cause it printed 2 pages ;( aaa.pdf (672.3 KB)

What size paper did you select in Document Setup? Why did you choose a template with a border and title block?

Go back and start over. Select the A4 vertical grid paper. After the viewport is displayed, go to File>Document Setup>Paper and choose A1 paper size. Set the scale to 1:1 for the viewport and drag the edges of the viewport until you can see the entire model shape. Move the viewport on the page until it fits within the paper border.

@batata003

SketchUp Pro is a full-time 3D modeling application.
Why struggle with a 3D modeler for simple 2D drawing?

Perhaps this PDF will print the way you need.
The PDF page size is A4.

Wing.pdf (100.2 KB)

@Geo what type of wizardry did you do? The file you attached is exactly what I need!!!

I agree with you, I should use layout to create my 2d drawings but I found layout sucks. For example, if I create a rectangle and them I use the line tool to divide this rectangle in two, the line gets saved as a separated object from the rectangle. In skecthup if I do that the line and rectangle becomes one single object… How do I do that in layout?

@daveR finally I got to make work what you said! I created a custom template with nothing and it worked perfectly! But I think creating the model in the 2D tool is a better way, but i am strugglying here with layout…

There isn’t any reason why you can’t do what you need to do with SketchUp and LayOut. If you want to only use LayOut, go ahead but it’s perfectly possible to use your SketchUp model. You decide which way you want to go.

2 Likes

There are times when the biggest tool isn’t the best tool for small jobs.


I did a video starting from opening your file to ready to print. First run through, no editing.

The page layout at the end is not exactly the same as what you should see because I don’t have a printer mapped that will handle A-sized paper.

2 Likes