How to print a 2D floor plan to scale of 1/4" = 1'

I have finished creating my first floor plan with SketchUp. It’s a 2D floor plan with furniture. I want to print it to scale now (1/4" = 1’). I have wasted so much time trying to figure this out but I cannot seem to get it done. I want to send the drawing to Layout and print it from there as I want to add the labels for the furniture schedule, and so on. What steps would you advise?

Here’s the steps I have been using (on MacOS Catalina), and I think I just got it to work with the .EPS format:

  1. In SketchUp, choose File: Export: 2D Graphic
  2. Choose Format: EPS and click Export Options
  3. Image scale: 1/4" in image and 1’ in model
  4. Make sure you click out of the box where you entered 1’ in model or it reverts (is this a bug? I might have been tripping over that), then click OK

In Layout, insert this image via File: Insert menu onto drafting paper.

It looks right to me now. Step 4 seems the step that was giving me trouble.

Any better workflow between SketchUp and Layout for 2D floorplans?

How about,
setup a scene in Sketchup, probably using Camera/Standard View/Top and Parallel Projection.
Save file, Use Send to Layout from the file menu.
Layout opens, choose the template you want.
Select the viewport which should be showing your scene and adjust the Scale in the Sketchup Model Tray.
Make any other changes and print.

1 Like

Do not export your Sketchup file, layout reads full .skp files, just save the file and follow Box’s instructions. Layout will allow you to insert EPS or DWG or other formats, but the workflow is designed around having full .skp files are embedded directly into Layout. You can then choose the scale and display details from within Layout. If your Sketchup develops further and is re-saved, the changes in the Sketchup file will be updated within the Layout file.

Hi there, thank you for the tip! I am still struggling with this… I tried both versions, the export one (which you said wasn’t the best idea) or opening the native .skp file directly in Layout. I don’t know but I am still super confused how to get this properly to scale. Maybe there are some steps in Layout I am missing. Here’s a short video that shows my confusion in full glory:

Any additional help much appreciated!

Heya Box, thank you for your response! I might need some more concrete tips here - I made a short video of what all I tried. I hope it sheds some light. Any additional help much appreciated!
Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

It looks like you tried everything except what I said.

Create a scene in Sketchup. This means you arrange the model the way you want to view it, then use the scene dialog to save that as a scene.
Then save the file.
Then use the Send to Layout option, choose the template you want, it will then open showing your Scene.
Use the Sketchup Model Dialog to set the scale of the Scene.

You appear to to be thinking of sketchup as a 2d application when in fact it is 3d, so all that confusion about why some things are filled in and others not is due to not understanding what you have created.
Spending some time at the Campus will save you many hours of frustration.

1 Like

Hello again, thanks for the additional note. I think I now have it. To summarize, here’s what I did:

In Sketchup:

  1. Move my model to the origin point (intersection of x and y axis).
  2. Choose Camera: Zoom Extents to maximize the current scene on the canvas.
  3. Create a scene using Camera/Standard View/Top and Parallel Projection.
  4. Save, then send to Layout.

In Layout

  1. Pick the grid paper I want.
  2. Model is now open in Layout, centered on page.
  3. Use the Sketchup Model panel to set the scale I want.
  4. Start adding documentation to my floor plan.

Thank you so much for your help!


That’s pretty much it. :wink: