Pressing ENTER to Search


#1

In the 3D Warehouse dialog (File > 3D Warehouse > Get Models.) pressing Enter in the search box should start the search. Presently, it does nothing for me.


#2

Hello @jim_foltz , what version and type of SketchUp are you using? I unfortunately am unable to replicate your issue. I am using SketchUp Pro 2015 and went to File > 3D Warehouse > Get Models, did a search and concluded the search with “enter” and it worked for me. Perhaps make sure that the 3D Warehouse window is selected? Are you still experiencing this? I am going to remove this as a “feature request” since it is already available.

Thanks for being a part of the community!


#3

It might be available but isn’t working for me either in:

SketchUp Pro 2015 / Version 15.1.105 32-bit


#4

Hi AlexB,

It still does not work for me. I am using SketchUp 15.2.685.

Here’s a video


#5

Funnily, using Ctrl-M did work.


#6

Thanks for your effort and posting the video. We will continue to troubleshoot this issue and keep you both posted on any updates. We are working to mitigate this issue.

Thanks!


#7

What operating system are you on and what IE/Safari version are you?


#8

I have the same issue and it is annoying.
Win7 and IE 11


#9

I use Win7 and IE11 version 11.0.9600.1751


#10

Hi @AlexB

I see the same problem on my system … Enter doesn’t work and Ctrl+M does
Win 8.1
IE 11


#11

Thank you all for letting us know, great feedback. We have made engineering aware of it and added a feature request internally. We know that Ctrl+M works on Mac and Windows, so I would suggest using that as a workaround until we report any updates.

Please make sure your Java is up to date - what version are you all using?

I can also report that we have reproduced this internally while using IE 8, Windows 7.

Thank you,
AlexB.


#12

What I don’t get is why Trimble isn’t following user interface conventions in something as simple as a search box.


#13

You are making an assumption that they did this purposefully. I very much doubt that.

There are many factors at play here.
Multiple SketchUp versions that can load various version of MSIE WebBrowser Control (what we call a WebDialog) and then there is the Browser version emulation setting in the registry for any “sketchup.exe” on the machine.

I also seem to remember that there were certain keys that were problematic in trapping from Javascript within MSIE. (I think it was security against browser hijacking.)

I am running MSIE 11, SketchUp 2015, and the browser emulation setting in the registry is set to MSIE 9 (ie, 0x270F, 9999 decimal,) and the ENTER key works just fine for me for in the Search box from a Webdialog inside SketchUp.

The ENTER key also works just fine for me, outside SketchUp in Chrome, Comodo Dragon (a Chromium build,) and MSIE 11.

<< This is an old report BTW >>


Win7 64-bit | SketchUp 2015 64-bit | MSIE v11.0.9600.17959 | Browser Emulation 0x270F (9999)


#14

I am assuming it is on purpose.

catching the enter key while typing in a dialog box in the embedded browser, and then posting the entered data, is the default. Unless they have changed it on purpose it should work this way in any windows environment. This has been a microsoft UI design convention since the first version of windows, and has been this way in every version of every graphical browser I have ever seen. I say graphical because I am not sure I remember how the text based browsers handled data entry.


#15

Jim, has this been fixed for you yet ?


#16

@jim_foltz Our intent is that ENTER will launch a search. Is that Windows 8? It looks like the search box is getting hijacked – you don’t have the helper text, ENTER doesn’t work, and there’s a little “x” appearing as well.

Is it the same experience when you launch your IE browser on that machine (outside of SketchUp) ?


#17

@Isaac, @DanRathbun I am using Window 10 - I’ve updated my profile. And yes pressing ENTER is working.

I don’t use IE, so not sure how it might have been hijacked. Other folk reported the problem also. But it is working as expected now.


#18

We don’t know what you’re talking about here, @Jeffery. It’s working as expected, and I just tried multiple versions, including IE Edge on Win 10 in SketchUp to confirm that.


#19

I am talking about the built in warehouse browser (file>3d warehouse>get models). all other browsers work perfectly.


#20

On your machine. On every machine I’ve tried it on, it works. When Jim originally posted this, there was a funky issue on a particular setup that we hot fixed. Shift-click on the search icon, copy the debugging info you get, and send it to me, and I’ll try to exactly match your env as best I can… but we’re not seeing it.