Preserve Scale Works Differently in Sketchup 2023 (?)

I am noticing the “Preserve Scale” function in the sketchup layout works differently in Sketchup 2023. Is this true for anyone else? And is there a way to make it work as it did in previous editions?

On my cover pages I typically show a perspective view of the assembly I have drawn. Because it is a perspective there is no scale to the image. In the old sketchup versions I could adjust the overall size of the image shown when “preserve scale” was unchecked. And then I could check the “preserve scale” box and adjust the overall viewport. This allowed me to adjust how much of the model I could see without changing the “scale” of it. Now when I click “preserve scale” and update the model, it returns to its original size/“scale”. I wish that this functionality still worked as it did on the sketchup 2022 and earlier versions. Does anyone know how to change this back?

The work around I am using currently is to not recheck “preserve scale” after resizing the model/viewport. This is annoying because it seems like the entire reason of having the preserve scale option is to be able to change the viewport on a non-ortho view.

Does that mean you are double clicking into the viewport to “adjust the overall size”?

I think that Preserve Scale feature has changed (IMO for the better) but it shouldn’t affect what you need to show with the viewport. You don’t need to click into the viewport to adjust the overall size.

Yes and you can still use it.


No I never click into the viewport itself.
In Sketchup 2022, I could just drag the corners of it to change its size (when ortho and preserve scale are unchecked). And then check the preserve scale to adjust the viewport size without changing the size/scale of the model.

Now when I check the preserve scale box, and try to adjust the viewport size without changing the size/scale of the model, it works inititially, but when I update the model reference. the size/scale changes.

OK. That’s different and yes, I see that as well. It hasn’t been a problem for me in my work before so I hadn’t noticed. @adam and @trent, any thoughts?


i hadn’t really checked this myself but i noticed several pages in my recent document the model/viewports changed when i refreshed … this is definitely not a good thing so hopefully it will get patched soon… @adam @trent

1 Like

@DaveR @glennmstanton @ridgelineJohn,

This is the same issue discussed elsewhere, but previously the discussion was about the camera position resetting:

Both the camera position AND scale are being reset for perspective viewports with preserve scale enabled during a model update.

We believe we have fixed this issue for the next release. Sorry for the inconvenience in the mean time.




This is happening to me too. I know Sketchup is working on it. Thank you!

It is a pretty big deal when you have Construction Documents where perspective viewports are scaled correctly and they all get rescaled. It takes quite a bit of work to readjust. Also the perspectives are no maintaining the correct scale when reloading the model. An update would be much appreciated so I can get the CDs back in order.

I love Sketchup and appreciate all the creative ideas you can produce with it. It seems as every time I update to the new version something gets messed up in Layout. I think I need to quite being an early adaptor of the new versions. This saddens me as I do like playing with the new features.

1 Like

Is there an update on this issue? I have the same problem and I cannot complete my drawings with all my viewports over 22pages continually rescaling in the new 2023 version every time I open the drawing whether i have updated the model or not. I have preserve scale selected but does not preserve anything.

I read on another thread that it was fixed and it will be released with the next update.

So what do we do in the meantime? I can work with how it functions now?

You could use the 2022 version until it’s fixed.

I have been unchecking preserve scale and then adjusting the viewport to the desired size. If you do not re-check preserve scale afterwards, the view will stay the same.
You may have to update your scenes to more precisely show/include what you are exactly looking for.

1 Like

Thanks I’ll try that

Yes my 22 version my subscription has ran out and now I only have 23 now. Can you swap your subscription to be back on 22?

Your subscription enables you to use previous versions as you like, but you can only be logged in to three SketchUps at a time.

How do you do this?
I imagine if you opened your layout in 2023 and saved it you will not be able to open in '22. Based on the: “If you save it with the current version, the file may be partially incompatible or unable to load in a previous version of LayOut.” pop up.

I have never needed to do that, but in LayOut you can Save As to an older version of LayOut. SketchUp files since 2021 use a bacward-compatible file format.

MADDENING! It’s been doing it to me, too. 2022 iteration, I’d set the perspective scene in Sketchup based on how it was viewed on my monitor. When setting the view in Layout, I could adjust the size of the perspective by unchecking “preserve scale”, increase or decrease size as needed, then recheck “preserve scale.” The size remained the same in Layout as nothing was adjusted in Sketchup. Now…Layout defaults back to the scene size in Sketchup regardless of “preserve scale” checked or unchecked. Absolutely maddening. RidgelineJohn is spot on. I do hope that it is indeed a known issue and will be resolved. - j

Try parallel projection and orthographic views in SketchUp, Then go to Layout.