Polycam > sketchup > sketchfab

Hi all,

Im currently trying to export a 3D model into sketchfab from SU that has got a polycam scan OBJ model in. Iv exported the model from SU as a DAE and uploaded into Sketchfab but the texture are not appearing in sketchfab on the 3D polycam scan.
see attached, The pipework shows the colours i assigned it but the polycam scan is blank. What do i need to do here to get the polycam textures included.

Note: i did not use the sketchfab plugin as everytime i try to download it i get a bugsplat.

How and what files did you upload to Sketchfab? More precisely, in addition to .DAE, did you also have the texture (.jpg, .png)? If so, did you link it to Base Color in the 3D settings?

There is a Sketchfab extension for uploading directly to Sketchfab from Sketchup. you might get better results that way.

You should also check your back faces as Sketchfab does not assign colour or material to these.


I tried the following:

non show textures in sketchfab. Not sure how to link base colour in 3D settings?

see note in original post. not sure why i keep getting bug spats… Very annoying.

Did you check back faces. Also check how many materials you have in the model I think there is a limit that Sketchfab will import so you may need yo cull some unused ones.

Since you don’t export the texture (.JPG, .PNG) from SketchUp, you have no way to load it into Sketchfab, and it has no way to guess what it looks like, and you have no way to link something you haven’t loaded.

I just tested with .DAE file and it works ok if you export and load the files correctly.

ah, are you using the pro-version?

ahha done it!

Yer it works if i Zip all the files together and upload. Spot on! thank you for the speedy help!!

much appreciated.

HI Sorry to be a pain,

How comes all of the flanges on my pipework are transparent in Sketchfab and in SU they are not? also is there a way to lose the straight edges on the pipework?

DN150 90 BEND.dae (456.3 KB)
here is a section of pipe i created and made a component.

In SketchUp, set the Monochrome style and make sure the faces are oriented correctly, with white outwards.

Those faces do not exist in your DAE file.

Humm, iv just checked and all whites faces are on outside using monochrome in styles.

Then… it means that for an unknown reason (for now) certain faces were lost between SKP and DAE.

I check once more, it is possible that the problem is only with the way the dae file was imported in SketchUp.

humm… even if i export just the 90 bend and DAE and upload to sketchfab they flanges are still transparent. I tried this as i thought the complete file may have been too big or somthing.

I tested with the same SKP file (I have created a new model) that I exported as a DAE file from both SketchUp and Blender.
In Sketchfab there are problems with the DAE file exported from SketchUp.
I have to test more.

Do you know a work around for this?

Export as OBJ. Or export from Blender.

Try this:
In Option (for DAE export), set ‘Triangulate all faces’

in Sketchfab it looks right

1 Like

spot on, Thank you for your help. This is a real project, im moving some pipework on a sewage site, using this so the client can have a look.