SU to Blender Texture Question

I’ve watched a few things on importing to blender and I’m not sure if I’m missing something. I’ve created a simple room in sketchup, but when I export/import to blender I just get a very cartoony, edgeless model with no materials/textures. I’ve tried both OBJ and DAE and it’s generally the same. I paid for some website that has Hi-Res textures and materials with texture maps, used those textures and still the same outcome. I get some muted colors, just no materials or textures.

Any advice? Thanks.

Here’s the SU model:

Here’s how the OBJ import looks:

Here’s how the DAE import looks:

There is an importer add on for blender. I will try to locate it. BRB

It can be found Here . You will have to save the file as a 2020 version to import it. It will NOT work with files saved as 2021 version.

The one I’ve seen linked in the forums no longer exists. I don’t know if there’s another.

See my previous post!

So I’ve got to save it as a v.2020, then from that point export it using this plug in?

Edit: I’m not sure what to do with the files in that ZIP files

Ok, it took a while, but I got the add-on installed and imported the 2020 saved skp.

I see this – still no textures:

See Viewport Shading


That helped a lot. Thank you.

Now I have to learn how to actually render the model

I wanted to follow up with a error I keep getting over and over. The problem is I get it work eventually, but it’s by luck/accident and I’m not really doing anything different except saving it over and over until it works.

I am saving my skp files as the 2020 edition, even though I use SU 2021 pro

Here’s what I’m seeing:

E: I’m using the sketchup importer add-on in blender to import skp files directly.
E2: I don’t even have to resave it. I can just keep ignoring the error, and then on like the 3-4th import attempt it will just work.

Did you get version 0.21 of the importer? Also is the file location of the folder referenced in the first line of the error a valid folder?

Yes 0.21.1

And I’m assuming that’s where Blender installed the add-on to. It exists, but it’s not a folder I ever would use manually … getting to find it required unhiding system folders.

Are these files in the folder?

Yes, they’re all there.

I am at a loss as to what is happening. My setup does not produce errors with the plugin.

I’m doing another model now … and 2 error messages and 3rd try it worked. I did nothing different, just kept trying to import the same file. Weird

E: And after I imported the 1st skp file, I tried a second and third skp file into the same blender model and they worked first try.

1 Like