Pointer slow to respond

win10
driver
windows10

#1

I am using Sketchup Make 2017 and the all of the tools seem to work just fine except for the pointer. It is very slow to respond. It will eventually do so but there is an unacceptable lag time. This is a new problem as 2017 has been working just fine. I have uninstalled and reinstalled the program twice without success. The problem is more or less coincidental with a windows 10 update but I restored windows to a point previous to the update and the problem still is present. I tried the web version of sketchup and the pointer works just fine there, suggesting that the problem is in my hard drive version of the program. Any suggestions would be appreciated.


#2

Many threads on this subject. Try this:


#3

Thanks for the link Dave. Those links suggest that it is a problem with the graphics driver. I have an Intel 4000 graphics card and I use an automatic driver update program that claims the driver is up to date. Any other suggestions?


#4

Intel graphics drivers are notorious for issues with OpenGL. It might be that stepping back a driver version will take care of it.

There have also been reports of issues with some Windows updates that caused major problems. See the second link I supplied and also this:


#5

Sounds like the update is also causing my problem. I will try and roll back again prior to that update though I’m not quite sure how to do that. I use DriverUpdate and on their restore points I can only go back two updates and I’ve already tried that. I will contact them and see how I run a restore further back than two weeks.


#6

A restore back to March fixed the problem. Thanks much for pointing me in the right direction.


#7

It would be helpful if you know version numbers that do and do not work.


#8

I’m sorry I don’t have that information. I rolled back a large number of items so I’m not certain which of the ones that were rolled back fixed the issue. If it happens again, I will do them one at a time so that I know which was the culprit.


#9

If your machine has more than one graphics processor, eg you’re on a Windows 10 laptop with both an Intel Graphics processor and an NVidia processor, then switch SketchUp from the Intel to the NVidia processor. To do that, close SketchUP and:

  1. Right click on Desktop
  2. Choose NVidia Control Panel
  3. Click the Program Settings Tab
  4. Select Trimble SketchUp in the Select Program list
  5. Select “High Performance NVidia processor” from the preferred graphics processor list
  6. Press the Apply button in the bottom right hand corner
  7. Restart SketchUp

Pointer should work properly now.

James Carr
Passive House Builder
For projects see Youtube


#10

James thanks so much for the suggestion - particularly since my pointer problem is driving me nuts. I am using an ASUS laptop that has been upgraded to Windows 10. Can you tell me how to find out if I have both graphics cards? As far as I can tell it is an Intel 4000 but I can’t seem to find a place where it tells me all of the hardware components… I guess I’m not tech savvy enough… Clark


#11

Well if you right-click the Desktop (as James said) and you don’t see a menu item “Nvidia Control Panel”, then you likely do not have the Nvidia driver utility installed. Perhaps you may not have a second “dedicated” GPU,… or perhaps a AMD/ATI GPU instead.

You can check my wiki in the second part about using the Device Manager:
[wiki] Where to find Hardware Graphics Info for your SketchUp forum profile

… OR, download and run the SketchUp Checkup utility:
https://help.sketchup.com/en/article/3000318


If you haven’t tried the latest direct from Intel, … (I know you said you had rolled it back a few versions.)
Here is link to the Intel driver for the HD2500 and HD4000:


#12

Dan, I down loaded and ran the checkup utility and it did not find any problems. I do not see the Nvidia graphics card anywhere on the machine. The pointer issue appears to be sporadic / inconsistent as it worked fine today. I’m stumped as to why it goes into slow motion sometimes. From: Dan Rathbun sketchup@discoursemail.com


#13

This topic was automatically closed after 91 days. New replies are no longer allowed.