Plugin Extension HouseBuilder How to INSTALL?

installation
extension

#1

New Sketchup user and it looks like from the YouTube videos on how to use Sketchup for designing a Tiny House, that the best plugin to use will be House Buider. However it does not seem to show up at all on the Sketchup Extension Warehouse site at all. I tried downloading it on a browser to my computer, but even after doing that the browser showed it put it in the Downloads folder, but the Sketchup program simply could not FIND it under the Window- Preferences - Install Extensions menu. It simply does not SEE any downloaded files for the House Builder. So I am completely stuck, the program does not allow me to install the House Builder Extension. And yes, we did find out we needed something called Ruby so we used something called RubyInstaller to install Ruby (which changed the House Builder icon from blank icons to colored icons like somehow that made a difference).

This program is way too hard to even install! Seems you have to be a computer geek to install any options. Help!


How do I install HouseBuilder in my SUMake 2015?
#2

Housebuilder is an older plugin, dating from before the extensions installer was added to the Preferences menu. It consists of a .zip file containing two .rb script files and a sample .skp. The two .rb files go in the Plugins folder.

You can install it in either of two ways:

  1. Rename housebuilder.zip to housebuilder.rbz and try using the
    Preferences > Extensions installer again. It should work. (You see,
    .rbz files are simply renamed .zip files.)

  2. Open housebuilder.zip with WinZip or equivalent (realizing you haven’t told us your
    operating system) and extract the two .rb files–the .skp too, if you like–into the SU Plugins directory.

Read the following article (which you should probably have already done): Installing Ruby plugins.

It seems to me that you’re setting the geek bar a bit low. Renaming and copying files is something any garden variety computer owner/user should be able to do on his system.

You don’t need to install Ruby to run Ruby plugins in SU. SU contains a Ruby interpreter. You simply place the plugin file(s) in the Plugins directory, restart SU, and rock and roll.

-Gully


#3

For the avoidance of doubt, this links to the current versions of HouseBuilder - both metric and Imperial,

http://sketchucation.com/forums/viewtopic.php?p=564448#p564448


#4

Hello. I had the same problem getting House Builder into 2014. Gully’s first option did not work, however, the second option did. So thanks to Gully. No another question regarding HB. In SU 2013, I was able to get the House Builder functions to show up in the top menu bar, but I don’t remember how I did it or if it was automatic. Anyway, is there a way to get the functions to the top menu bar in SU2014?


#5

Odd. It did for me, installing into 2015.

-Gully


#6

Well I tried the option of trying to re-zip the folder (could not find anywhere in Windows to stop it from auto-unzipping) and then adding the rbz extension. Sketchup then saw that Folder (it has a whole lot of files in it) but did not seem to do anything. Sketchup then opened up that folder and there was nothing there, it just said No Items Match Your Search. So no-go on that approach.

On the other approach of copying & pasting the unzipped files directly into the Sketchup Program – The House Builder actually came with a diagram of where to put the files into the (Sketchup 5) files tree, but that tree of files doesn’t look anything like the Sketchup 2015 files. The new one doesn’t even show a Plugins Folder. Besides, why should lay people mess around with the program structure of a Program File??!

Like I said at first, this whole process of trying to get House Builder to load into Sketchup is way too geeky and the solutions offered simply don’t work. MAKE IT SIMPLE AND EASY TO USE PLEASE.

Btw, why is it not showing up on what appears to be the “simple & easy to use” method which is that Extensions Warehouse website?? Does anyone know why this House Builder Plugin, which could certainly be one of the most widely useful & popular of Plugins for Sketchup, does NOT get listed on the Extensions Warehouse??


#7

In my version of 2015:
C:>Your User Name>AppData>Roaming>SketchUp>SketchUp 2015>SketchUp>Plugins

Can you not find the plugins folder in your version of 2015 using the above path?


#8

The folder may not be there if you have no previously installed plugins, so just create the folder in that location, which is what SU would do if it were performing the installation.

-Gully


#9

Likely because the original author (and copyright holder,) wrote this old and ancient plugin script, back many years before the SketchUp Ruby API had a SketchupExtension class, and long before the Extension Warehouse was even an idea, much less a reality.

[quote=“craigaseverance, post:6, topic:10267”]Does anyone know why this House Builder Plugin, which could certainly be one of the most widely useful & popular of Plugins for Sketchup, does NOT get listed on the Extensions Warehouse??
[/quote]
Because we live in a free society and we do not force people to join a web service.

Listing on the Trimble Extension Warehouse requires applying to become a EW Developer, and adhering to a Developer Agreement, and packaging extensions in a certain technical way, including instantiating a Ruby SketchupExtension object for the extension. Lastly it also requires a developer to actually set up the extension store page, and pass the EW critical review.

The original plugin author may not even be involved in writing SketchUp plugins anymore. Or they may be a “hobbyist” and not have the knowledge to bring the plugin code up to date, in order to meet the minimum requirements of the Trimble Extension Warehouse.

Quite a few old, yet still useful scripts, have been abandoned. Some people just go on to other things in life.

Anyway, … things just do not happen automatically.


#10

EXACTLY, why it was moved.

But why was it ever that way, and what took so long to move the scripts, plugins & extensions into the USER path folders ?

Ruby. SketchUp had to use the 1.8 Ruby branch before the 1.9 & 2.0 branches were available. Ruby 1.8 had no unicode string support. That meant that things would break if the username had unicode characters in it. Ruby just could not handle path strings that had special characters in the users name. (Often this is the case for non-English names.)

Although the Mac did not have issues in this regard, SketchUp still had to wait until Ruby caught up to the Unicode world, before it could fix things under MS Windows.

We also had serious issues with folder permissions beginning with Windows v6 (Vista and higher.)

Things are MUCH better now!


#11

THANK YOU! That solution finally worked, there was no way I could have
figured out where to copy-and-paste those files without you specifying
the 2015 Sketchup tree, especially since the diagram you get when you
download the House Builder is apparently obsolete compared to current
Sketchup tree.

Since it was suggested by someone else that with no Extensions yet
installed there would not yet be a “Plugins” folder in Sketchup, I went
on the Extensions Warehouse and picked out an Extension to load. So
first I loaded a trial version of another (much less useful) Extension
from the Warehouse. /Then /I went in and copied-and-pasted the
downloaded House Builder files according to your new “tree” instructions
and it seems to now show that it will work. In other words, under the
Sketchup “Draw” menu there are now HouseBuilder Draw tools showing up.

I also appreciate the explanations that were offered about why this very
useful House Builder Extension program is not showing up in the
Warehouse. It is a pity nobody took that forward, but for now, you
folks saved us.

Yes, from my totally layperson perspective, this solution was still
pretty “geeky” but you folks had that knowledge to help make this work!
Will try it out later today.


#12

Had you bothered to follow my link in an earlier post it sends you to two RBZs on SketchUcation.com, one Imperial, one Metric.
http://sketchucation.com/forums/viewtopic.php?p=564448#p564448
It’s free to join SCF and download.
Once you have the RBZ you can simply install it using Preferences > Extensions > Install… button.
As far as I know it works in all SketchUp versions…
No need to mess on with ZIPs etc and manually installing files at all !
:worried:


#13

On mac at least, installation is easy. Copy a folder and an .rb file to sketchup plugin files. The imperial version works, but the metric version does not work. Does anyone have any suggestions?


#14

Have you tried downloading the two files linked in the post above?
http://sketchucation.com/forums/viewtopic.php?p=564448#p564448
You’ll need to be an SCF member or to register at SketchUcation.com [you can choose the limited free option… and still see links, images, files and download etc], and log-in…
Then, simply download the latest imperial/metric version RBZ files, and install those using the built-in Preferences > Extensions > Install Extension… button ?
Everything is extracted and put into the correct Plugins folder and subfolders etc as appropriate…
This is available on all SketchUp versions since v8M2…
It was invented several years ago to avoid all of these issue of finding folders etc and trying to botch a manual installation…
It should work on MAC :astonished:


#15

Indeed! Both the imperial and metric versions work on Mac when installed correctly using the .rbz versions supplied at the link TIG has provided three times in this thread.


#17

Hey Gully…in v2015, there isn’t a “plugin” folder…but the “tools” folder seems to have replaced the “plugin” folder…

Ozekisan


#18

@Ozekisan
You are sorely mistaken.
You should NEVER use the Tools folder, this is solely for SketchUp’s own files.
I suggest you remove your things and install them properly in the Plugins folder…

That video is an ill-advised and potentially dangerous divergence from the correct path…

Since v2014 each User gets their own SketchUp Plugins folder.
To find the path to it use this snippet in the Ruby Console:

Sketchup.find_support_file("Plugins")

However, you’ll rarely need to access this folder.
Almost all Plugins/Extensions [aka 'scripts] are now supplied as RBZ archives and these can be automatically extracted and installed for you in the correct locations, keeping files within subfolders as appropriate…
Many scripts have been updated to suit changes to SketchUp since v2014, so installing earlier versions may well lead to incompatibility errors…
Always get the latest versions of scripts and install then using Sketchup's [Window >] Preferences > Extensions > Install Extension button and simply choose the RBZ - everything is automated thereafter…
Manually extracting and copying files around is a sure-fired way to get issues…


#19

@TIG Hey TIG, as I stated previously, in v2015, there is no “plugin” folder (that I’m aware of) , but Ill see if I can access with the info you’ve given me…
Thanks again for the “guidance”…


#20

If you install via the Install Extension button in the Preferences menu, you don’t even need to know where the Plugin folder is.


#21

@TIG Hey TIG, sorry to bother you, but what all should be in the “tools” folder? It looks like there is only stuff I added in there…

Thanks
Ozekisan