Please help old-style icons .rbz

sketchup

#1

I want to change old-style icons . rbz


#2

I’ve used IconPackager myself to change icons for file types: https://www.stardock.com/products/iconpackager/


#3

Wait, has SketchUp changed the icon for extensions to be the generic SketchUp icon?


#4

Not that I’m aware of. But if you try to Open With and set SU to be the default app for RBZ then Windows will change the icon. (SU isn’t able to open RBZ files like that by the way.)


#5

I just recently got a Windows 10 machine. I cannot figure out how to undo an Open With … with the always checkbox. The “FileTypes” panel has been removed for the Folder Options dialog where we once could control these things.

In addition it is weird that on this machine the SketchUp RBZ icons got copied to the root of my D: harddrive, instead of the OS SSD. Apparently the SketchUp installer just uses the drive that the installer exe is on.
(Ie, I set Windows to use a Downloads folder on the traditional drive, and also have a large “INSTALL” folder on this drive as well with categorical subfolders for different types of software.)


#6

If you right-click, Open with, Choose another app, the dialog where you chose that app has a checkbox in it, to say Always use this app to open .rbz files. If you have done that previously, just do it again, and you can check the box again.


#7

… and thereby uncheck the box ?

And you purport that this will reset RBZ files to the icon that the SketchUp installer sets ?


#8

No, if you have previously checked the box to say always open with some other app, and you choose Open with, Choose another app, the box is unchecked again, on the assumption that you’re justing doing this one time. You can check the box to say to open with that new app.

I don’t seem to have any RBZ files on my computer, but I tried the steps with an RB file, and the icon does change (in this test I had previously set WordPad to be the app to handle RB files, hence it starting with a WordPad icon):


#9

okay, but we are not trying to set the Open With… and hence to icon to another app.
We are trying UNDO that, so that no app is assigned as the default “Open With” app, and then the default file type icon that SketchUp installed will be used.

FYI, @sWilliams sent me a clunky workaround from a forum posting that sounds like it will work. But it is far from friendly. It requires creating a temporary .bat file to serve as a temporary “Open With” app. After changing to the batch file, you’d delete it, and then Windows would “clean up” the Open With settings when it cannot be found, which should reset the file type to the default icon.

For me (as a geek) it would be easier and quicker to navigate in the registry to the filetype and manually delete the Open With command.


#10

Thank you everybody


#11

I had been talking about how to do what Thom had suggested. But I finally understood what you were actually asking!

Found out how to use the Default app settings in Control Panel to reset all file types to the Microsoft defaults, that fixed RBZ for me, though on my strange hybrid setup it though Xcode should be the default!

I dare say you don’t want to have to reset all file types for the sake of RBZ! I found this article:

https://www.tenforums.com/tutorials/8703-restore-default-file-type-associations-windows-10-a.html

which does have a list of files you can download to reset some file types, but not surprisingly RBZ isn’t in the list. But maybe there’s enough clues in the ones they have to figure out RBZ. I’m not sure, I’m not a Windows expert.


#12

Yes, reading the ".reg" files tell you where in the registry the settings are held.