2015 is not recognized after 2016 uninstall


#1

I am currently using Pro 2015 (on windows 10) but installed 2016 to check it out. A day later, I uninstalled 2016, but now none of previously created SU files (which were not even opened in 2016) are showing an icon. Upon double-clicking a blank SU file icon, it opens the Open With window and only shows 2016 as the recommended application to use to open the file. I have to right-click on any old file and choose Open with 2015in order to open it.

Any help is appreciated.


#2

Have you tried to assign it as the default app for skp-files?


#3

Right-clicking on the file and selecting Open with... and making sure you check the box called Always use this app to open .skp file, click on Look for another app on this PC and browse to your SketchUp 2015 binary executable (.exe file)

By default the 64bit version is located at:

C:\Program Files\SketchUp\SketchUp 2015

and the 32bit at:

C:\Program Files (x86)\SketchUp\SketchUp 2015


#4

Thank you for the swift replies, I really appreciate the help.

Forgive me - at work running win 7 enterprise. Apologies.

I am unable to get 2015 to show up in the Open With window. I can browse for it, but only 2016 will be visible in the list of appropriate applications for the file.

This is the right-click OPEN WITH menu, then browsing for 2015, and then this is what happens when I select 2015 top be the app to open the file I right-clicked:

I have not opened the file in 2016 when it was installed and this is not a file that was created in 2016. All of the files created prior to the installation of 2015 (I have thousands) are affected the same way as the file in the images.

When I double-click any skp, the OPEN WITH window pops up, just as the first image.

Thanks again for any help!


#5

It has been reported that SketchUp versions fight with each other over setting the “open with” flag in the registry. The most recently run version overrides previous ones. You may be able to get things straightened out by simply running SU 2015 and opening a model from within it.


#6

if nothing helps, just install version 2015 again.