Change default SketchUp version (Windows)


#1

Hi! For debugging purposes, I’ve installed several versions of SketchUp on my Windows computer, but most of my models are 2016 models, so I want to use SKP 2016 by default when double-clicking. However, when I double-click, it opens SketchUp 2014 and I was completely unable to change the default file association to SketchUp 2016, either by the Control Panel, switching back and forth between association with SketchUp and with Notepad… And Windows Default Programs in the Control Panel says each and every version of SketchUp I have is associated with .SKP and .LAYOUT file extensions.

Oh and I can’t uninstall because obviously SketchUp 2016 is my dev version for my plugin and where I have several paid extensions and the Pro licence and I’m afraid with uninstalling I’d lose all of that.

Help please…


#2

If you “right click” on the file you want to open…choose " open With" and go find the Sketchup 2016 exe…and tell it to open with that …tick “always use this file to open”…that should do it.


#3

Did not work, still locked into SketchUp 2014 which is exactly the problem…


#4

Can you not make all SKP files open with only 2016 's exe ???


#5

Whatever I do, if I select the 2016 EXE in “Open with” or “Default programs”, it will keep being locked to the 2014 EXE.

And editing the registery does not help either, as it seems like Windows does not store the full path to the app, and thus has no mention of the 2016 version in its Registry in the Default Programs Registery Key


#6

A little drastic…but another way i have gotten around this kind of thing is to "rename " the 2014 .exe file ( you can change it back later )…then when you try to open your file it won’t have anything to open it with…so tell it the 2016.exe file if it asks ‘what should i open this with’…worth a try.


#7

Yeah, I did the opposite and renamed “Sketchup.exe” into “Sketchup2016.exe” and it worked! :wink: Thanks a lot


#8

Yay…glad it worked…i’ll go have a lay down now…lol


#9

There are two different ways of changing program defaults in windows 10, and the new way just doesn’t work.

You must find this page

and set it to default.

Or at least, this is how I fixed my issue when I had your problem.


#10

Well, I’m sorry to tell you this doesn’t work either. It keeps being locked to SKP 2014 if done this way.

Oh, and BTW, since I did not mention it, I’m on Windows 8.


#11

I have the same problem and have gone through the same steps.
I would be thrilled if someone discovers a solution.
I guess I could change SketchUp.exe to SketchUp2016.exe, since Wolfy says it worked, but I don’t feel entirely comfortable with that solution.


#12

formerly the SU version launched latest grabs the file association with the SKP file extension and is therefore launched if double-clicking a SU document * iirc *

… but may have changed with recent versions.


#13

I’m having the same problem. Until recently, everything worked fine. I had both 2015 and 2016 installed, and SKP files were opened by default with 2016, which is my preference. I upgraded from Windows 7 to Windows 10 earlier this year and this continued to be the case. However, I ran into a lot of other problems with Windows 10, and I recently had to go back to Windows 7. I installed 2016 first, then 2015. Now, my SKP files are opened by 2015. Perhaps this is related the sequence of installation. I have tried changing this through Windows using the option to “Associate a file type or protocol with a specific program” under “Default Programs,” but it has not worked. I don’t understand the solution that did seem to work – renaming a certain file. Can someone describe that process in more detail?


#14

I never figured a way to remove those options on the right mouse button click on skp files…

now 2017 will be in there too :stuck_out_tongue:


#15

“Start > Windows Search: regedit > Search: Open with SketchUp…”

don’t mess with the Zoh… * ahum * Registry!