Open File Starts An Older Version Of SketchUp And Not 2023

For the life of me I can’t find the previous forum posts that discuss this issue.

When I click on a SketchUp file it opens with version 2022 and not 2023 – yes I have installed as administrator.

And why, when I right click and choose open with, I’m presented with four 2017 versions when I have uninstalled 2017 !!

Screenshot 2023-02-17 112855


Clicking on a Layout file opens with version 2023.

When I click on Choose another app and navigate to the SketchUp 2023 exe file it still opens with 2022.

Probably OS related, I am on Win 10. Clicking on the .skp file opens it in the 2023 version. How long has it been since you have done a clean install of the OS?

The machine shipped with Windows 10 and I have had automatic updates enabled.

When Windows 11 became available I allowed Windows to update my machine to 11.

I found this post from Colin…

And it worked for me then but right now when I try to choose the default app, 2023 is just not available just the bunch of f @#$%&! )ing 2017s.

I have 2020, 2021, 2022 and 2023 installed and all except 2023 are available to choose as a default app.

Windows 11 does this feature in a better way. Having typed .skp for the file type, it then showed I had SketchUp 2019, with the new icon, for the default app. My list of other apps included three other SketchUp 2019s. As it happen, the one of the four that was chosen was 2023, so I chose the 2019 with the old icon. Double clicking a .skp then opened 2019.

Going back to the list I tried others in the list of 2019s, then noticed something:

As you choose the various 2019s (in my case) you are shown what the real version is.

So, try whatever SketchUps you see until the selected one includes SketchUp 2023 in its title.

Thanks Colin – I tried that but it wasn’t working.

But… I now have only 2023 on my machine and everything is hunky dorky for the time being…