Windows 10 not Showing Sketchup for Open With

Hi, getting used to Sketchup after a few months. I am using Pro on a laptop running Windows 10. When I try to open a Sketchup file in Explorer by right clicking and picking Open With in the flyout Sketchup is not offered as an options. In addition the icon on the file is a pdf although the extension is .skp.

When I ask the computer to find the app in the Windows Store Sketchup is not offered. There is a school version.

So the only way I can open a file is to load the program and go File>Open to search for the file. This is a big issue and I am trying to have 2 instances of the program open with different files so I can copy and paste between the files.

Probably an installation issue. Close SketchUp, find the downloaded installer or get it from Download All | SketchUp Right click on it, choose Run as administrator, and then choose the Repair option.

Thanks, where do I find the “downloaded installer?”

If it’s not still on your computer in the downloads folder, get it from the link I provided.

I did as directed and restarted my computer but it didn’t work.

Which version of SketchUp Pro did you install? Please complete your forum profile.

You can set the default programs in windows 10 via the Windows 10 “default apps” setting area.

Type “default apps” into the window search
or press windows key + I
goto apps > default apps.

Find your SKP file and change it to SketchUp.

Nope, Sketchup is not offered as an option. When I choose Look for an App it is not represented in the Windows store.

And I don’t know where to go to include my version of Sketchup in my profile. I did input that infor when I set up the Forum account. The info is in my Trimble account. I am using Sketchup Pro 2022.

You need to go to: Settings>Apps>Default Apps>Choose Apps by File Type. Scroll way down the list until you find .SKP on the left.

It is there in the screenshot. But .skp is for some odd reason linked to Acrobat. And there is no “Browse for another app…” button (or how it happened to read when I last saw it)

I have Windows build 22H2 19045.2546. It correctly shows the association for the file extension .SKP. Also, there is an option to change it. Perhaps there is something afoot with his Windows installation.

Try another Windows method
Find a SKP file
right click on the file and select “open With”
select “choose another app”
tick the box to “always use this app to open .xxx files” (so that you only have to do this once for each file type)
scroll to the bottom of the list and click “more apps”
scroll to the bottom of this longer list and click “look for another app on this pc”
navigate to the executable of SketchUp in the Program Files folder
and click open.

That should set it