Please help! Axes have appeared and cannot be removed?

advice

#1

Hello fellow Sketch Up users!

I’m a very new to Sketch Up, but I’m learning fast. I’m having an issue with an axes that randomly came up when I was trying to move a window, and now I can’t remove it at all - does anyone know what this is, how it got there, and how I can get rid of it??
10

Thanks,
Kate


#2

Did you try Window>Model Info>Components and untick the box for Show Axes?


#3

That’s a really obscure place to put that parameter. I’d forgotten it was there.


#4

I don’t know. It’s related to components and I don’t know where else it would go.


#5

Have looked at that and the show axes box is unticked.

I have absolutely no idea how it got there - I guess I was trying to make the window hole a component and that’s how it appeared? I certainly didn’t try to put it there!


#6

How about uploading the SKP file so we can take a look? If you don’t want to make it public, send it in a PM to me.


#7

Living Space Sketch Up.skp (1.5 MB)

Here you go… let me know what you think!!

Thanks for all your help!


#8

would an imported model from 3DW import that parameter?


#9

This is what I see in your model? No axes where you show them. Perhaps quit and restart SketchUp and reopen the file.

Your model needs some help. You shouldn’t have all those reversed faces in the walls of the room.

If the component was open for editing you would see its axes but there isn’t evidence in Kate’s screen shot that the window component is open for editing. When it is, the axes aren’t located there.


#10

I’ve imported lots from 3DW but it’s never done that before.

That window is one I have used lots, including a second time in this one particular CAD.

I tried deleting the window model but the axes is still there :frowning:


#11

Closed it and reopened… the axes isn’t there - thanks!

Should always try turning it off and on again… should have known! Thanks anyway.

What do you mean by reversed faces in my walls? My models will most definitely need help - this is just my third day of using it so I’m still really getting to terms with it!


#12

I’m glad that fixed it. Sounds like some spurious signal or something.

The blue faces are the backs. White is the front. You want to keep up on face orientation because reversed faces will make your model more difficult to work with.

Since you started with a rectangle on the ground plane and drew your wall outlines before pulling them up, it’s normal for them to be reversed. The first thing to do is reverse them all before moving on. Select the geometry, right click on it and choose Reverse Faces.


#13

Got it - will remember for next time.

Thanks so much Dave!


#14

I think I see what happened although I can’t view the model in 2017. There was a guide line that was made into a component. Why it wouldn’t go away when deselected is odd though.


#15

FWIW, if you start by giving the floor some thickness before you draw the outline of the walls, correct face orientation will automatically be covered.

When you pull the walls up they’ll have the correct orientation.


#16

Well, there are no guidelines in the posted model. There are some guide points but no guidelines. No components show in the In Model components collect that are just guidelines, either. If that was the case they must have been deleted and purged. There are plenty of other components that could be purged since they aren’t being used in the model. This makes me thing there was no purge done before.


#17

There is a guideline in the first image posted in the same place as the problem axis symbol. If you make a guide line a component then open for edit and then untick guides in the view menu the axis symbol remains.


#18

Yeah but it’s not present in the uploaded SKP file. Since there isn’t a component with a guideline in the file, it’s not possible to say what was going on for sure.


#19

Btw the comment about reversed faces as “normal behavior” was funny.


#20

Why is that? If you only extrude part of a surface towards its back side, the faces should be reversed. That is the correct behavior.

If you were working from the front face you would expect this same behavior, too.