Plane alignment sometimes does not match when using inferencing at corners


#1

While drawing a floor plan, looking down on the x,y plane, I use the rectangle tool and inferencing to connect at corners as I draw walls and rectangular spaces. I find that eventually, as the drawing becomes a bit larger that I experience issues with the points at the corners not aligning properly with one another. This causes problems when trying to add patterns, textures and using the push-pull tool. The drawn rectangular planes also seem to not always be in the same plane (z=0); off by miniscule amount which is just enough
This problem is not visible unless one zooms in as close as you can get. Then the rectangle edges can be moved to meet. Sometimes I find there are extra lines present that I must delete.

Sometimes I draw several rectangles and use the same corner point as the anchor point for each of them. Though drawn using inferencing the corners are not

This repeatedly occurring issue takes loads of times to track down and correct.
I see architects producing rather complex successful projects, and I cannot believe they are having this issue.


#2

Can you attach a sample model showing this behavior so we can track down why.
Use the 7th icon from the left at the top of the message window to attach your model of less than 3mb.


#3

You are right, we don’t.

It can help to start with a flat XY plane onto which you draw your rectangles and lines. That helps ensure everything is “in plane”. When you’re done, just erase parts of the plane you don’t need.


#4

Also, be careful if you enable SketchUp’s position snapping feature (to snap points to every 1/16th of an inch say). This can wreak havoc if an existing endpoint or center-point etc. is very close to a grid snap interval. The inferencing offered by SketchUp may cause you to choose a position you did not intend (the existing endpoint vs. a nearly grid snap point).


#5

I see skp files are acceptable but skb files are not. When I look in my file folder I see only skb and SU Model files. How do I create a skp file??


#6

Test 3-30-18.skp (1.9 MB)

Please see skp file.
First, I would like to thank all of you for taking time to comment. It is Very Much appreciated!
Under the Camera pull down menu I have selected “Parallel Projection.” Also, I have created four scenes and added colors to the areas within each scene to call attention to the problematic areas I have questions or comments about.

Scene 1:
Would like to understand why, when the line between green and yellow rectangles is erased a hole results rather than another rectangular shape.

Scene 2:
Would like to understand why, when I drew the line creating the salmon colored square, the large rectangle above did not fill in.

Scene 3:
This view is extremely zoomed in. I am showing an example of a problem area similar to many I have been able to create in the past without trying to. When I drew the corridor I was not expecting to see:
(a.) the dotted ray which you can see between the green and light blue areas in upper portion of the scene.
(b.) the horizontal lines highlighted in light salmon, red and blue. I believe they are occurring when I draw several rectangles and the corner points do not align. Could be wrong about this… Looking forward to your comments.
(c.) I will note that the rectangular space just left of the light salmon color will not accept a color fill. Not clear to me why.
Scene 4:
Note the dotted ray lines. You can see that when I poured in the green color, it did not fill the larger area of the bed rectangle. Would like to understand what causes the rays.


#7

Unfortunately there are quite a few things wrong with the model. It’s hard to begin.

Maybe you should start working with groups and components instead of having most of the edges and faces in one and the same context.
For instance: select the dining table and its six chairs and right click > make component > apply [glue to: any + cut opening + replace selection with component] in the ‘Create Component’ window.
Do so for all the furniture, the kitchen counter etc. and assign some relevant named layer to them. Once you turn off that layer you can better focus on the walls and floors. Redrawing parts to correct geometry would be easier.


#8

Did you import the original model from dwg/dxf or other format and then start editing from there? The model is littered with extremely short edges and narrow “splinter” faces that are confusing SketchUp and causing the strange behaviors you see. As @Wo3Dan observed, there are so many issues you’d probably get to the end faster if you start over and redraw it all in SketchUp using a large reference base rectangle and with edge length snapping turned off.

As an example, here’s a close look at your scene 1:

For that specific issue, I dragged a selection box around just those two rectangles, and look what I got:

There aren’t two rectangles there, there are 60 entities. A deeper analysis using Ruby console shows there are 17 faces using 39 edges and 4 tiny “loose” edges not bounding any face! These glitches are so tiny they are essentially impossible to see in the SketchUp view because you just can’t zoom in so close that features a few thousandths of an inch are visible!

As an unrelated issue, you are using SketchUp’s layers in a very dangerous way (that might also have resulted from a dwg/dxf import): you have 4096 edges or faces associated with layer1. Layers in SketchUp do not isolate geometry from interaction, and that might be part of your problem. Always leave all edges and faces associated with layer0 and use other layers only for groups and components.


#9

Yes, there are many very short stay edges in the model, confusing SketchUp’s inferencing engine.
Here’s another example of the kitchen island that I grouped and looked at:

Entity Info should have only showed two edges instead of 6 edges.


#10

So, for architectural drawings is the recommendation a larger snap (say 1/2"), rather than no snap at all?
Will


#11

Wo3Dan,
I am beginning to understand… It is actually really necessary to use groups and components in an organized way throughout the drawing development. I will work this into my drawing process more. Previously, I must admit I was just drawing away and not using layers, groups or components all that much.
Thanks,
Will


#12

I’m not an architect; I use SketchUp for mechanical drawings. Be that as it may, I never use length snapping. When I want a precise dimension that does not have a pre-existing inference target I just type it in when creating a shape, or positioning a guideline, etc.


#13
  1. No, nothing was imported. I actually had an older drawing all done in SketchUp that was much larger with iterations of floor plans, furniture etc. Because of that, I went to town with the eraser and attempted to just present the segments which were confounding me.
    I’d like to say thanks for the recommendations. I will follow your advice; adding the reference plane and turning off the edge length snap.

  2. Entity Info: I won’t forget this one! I had to laugh out loud at all the things you found.
    But then you note,

  1. I am going to have to read up on the layers. :roll_eyes: I am such a rookie, it’s a bit embarrassing. Nonetheless, this is why I came to this group. I am seeking information and perspective and you all have it. Thanks for sharing it.

4096 edges or faces still associated with this layer… I’m thinking all the selecting and deleting I did to produce 3 neat little drawings with ‘a few issues’ must not have deleted the “associations.”
Note to self. Look up Ruby console.
Will


#14

TDahl,
I took a little time and perused your bio and many of the drawings you have posted. Wow what a collection you have. If I may ask, did or do you actually work in association with the Space Program? I too have have watched with interest the many accomplishments NASA has been associated with. Even got to take a tour of the launch pad used for launching the shuttles. Boys and their Toys. Massive Toys.
Recently watched “The Farthest – Voyager In Space.” Knocked my socks off what they accomplished. Now if I could only get my 16-yr old daughter to watch it with me.

I am a semi-retired architect, also have an Art degree. Over the years I have enjoyed dabbling with SU, but now that I allegedly have more time I am diving into SU more. The profession drew me away from drawing for the longest time, but I have always been drawn back to it. SU is a wonderful tool. This is my first time to the forum and I must say it has been a positive experience. – I’ll likely be back with more rookie questions.
Time for me to start my current drawing over. :sunglasses:
Will


#15

That’s how I started too. And got me into awful scrapes!

If there were five basic lessons for using SU, one of them would surely be to group early and keep grouping. It’s not going too far to say that nothing should be outside a group of some kind and many groups will have sub-groups. Another tip for newbies is to recognize the power and usefulness of the Outliner. It halps show how groups are organized and allows you to navigate to them and move them around easily.


#16

Hi Will, thank you for the compliment. I have never been in aerospace professionally, sadly. It’s a lifelong “hobby” - a rather deep one, to be sure. My interest in the Viking '75 Mars project goes back to my high school days during the missions in the 1970s and early '80s. In the past six or seven years I’ve gotten pretty serious about studying Viking, arranging research visits to a number of institutions: Smithsonian NASM, Virginia Air and Space Center, California Science Center, Museum of Flight, NASA Langley (home of the original Viking project office), and the folks behind the Viking Mars Missions Education and Preservation Project, who have quite a collection of original hardware and documentation.

SketchUp has been a mostly-enjoyable tool to use for my years-long ongoing project to create a high-fidelity Viking lander 3D model. I make the work-in-progress model file freely available, and SketchUp Make (and now SketchUp Free in the web) allows people with a moderate computer to see and experiment with the model. That’s one of the main reasons I chose to use SketchUp - so that others could work with the model for free.


#17

I know it must be incredibly easy to find, however… Could you please direct me to where the edge length snap can be turned off.


#18

Go to Window Menu -> Model Info -> Units -> Enable Length Snapping (untick it)


#19

McGordon,
Much thanks for your quick reply! Now I won’t have to drive to the liquor store.:sunglasses:


#20

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.