Precise Intersections

This has plagued me since starting w/ Skp in 016: after building edges and surfaces as precisely as I can, when I build intersecting edges, snapping to the original, these fail to be coplanar and thus will not form surfaces. If I zoom in VERY CLOSE, I can see that the original edges and planes do not actually intersect. There are gaps & overlaps. Thus the new edges are snapping to various points rather than one intersection. [see jpg screenshot below - the distances involved are less than a millimeter] ANYONE KNOW HOW TO AVOID THIS PROBLEM?

The result you describe suggests that you are not using the inference engine appropriately. Two relatively simple suggestions may help somewhat.

  1. Use guidelines to help keep your model’s edges coplanar.

    or better yet,

  2. Construct a square (or rectangle) of a size large enough to have your creation fit inside that geometry. Develop your edges directly on top of the geometry. This will ensure that everything modeled over the square (or rectangle) is always in the same plane and the original square/rectangle can be deleted once you have push-pulled your modeled entities into a 3D form.

If you upload an example skp file, we can take a look and confirm the nature of the problem.

Screenshots typically lead to guesswork.
As has been said, sharing an example .SKP file would help us help you.

My guess
Look to the top menus … Window > Model Info > Units
There, disable Length Snapping and set Precision to at least three decimal places or higher.

Disable Length Snapping


Understanding SU’s system of dynamic guides and snap points, Inferencing, is essential to happy modeling.
Modeling errors tend to go away after one learns how it works.
Here’s a start…


These are promising and much appreciated responses. SORRY about the .SKP omission. I see the point. Haven’t figured out how to do that quickly. I have worked hard at worked inferencing, guidelines, and snapping technique, but not come across these Trainings. Plenty to go on now. SHOULD HAVE ASKED 6 MO. AGO. THANKS LOADS.

As @Geo Pointed out, you will want to turn on snapping. Also, unless you NEED such a small increment, consider upping your snapping length (1/64 seems awful small for the size of your model).

15 AM

Architecture Guru recommended the 1/64" snap for accurate drawing. Geo suggests moire than 3 decimal places. So maybe thats wrong. If set at 1/4" cursor may find end points better you think? Geo said disable length snapping, which it was although he could not have known at the time. Haven’t had a chance to try advice yet. Gotta run tests. Thanks all.

Well, I know better than to argue with @Geo! I was making a recommendation based on the model you shared.

Personally, when I draw something that is ARCHITECTURAL, I set my precision to something that can be built to, like 1/16". Then I am conscious of where I am snapping to. As Geo recommended, take a look at the videos about inferencing and snapping and know that snapping is based on your level of zoom. The farther out you are zoomed, the less control you have over picking points to snap to.


So to kill the dead horse, here are 3 attempts to apply recommendations: First I created a stair tread and riser using my best inferencing and snapping skills. Then made them a group. Then made 3 copies, positioned laterally.
Then with each of these, I used M+ > x 3 to array 3 more snapping, from a vertex of the tread, to a vertex of the riser. For #1 I set Units precision to Architectural 1/16" w/ “enable length snapping” checked. For #2 I set Units precision to Decimal 0.000" w/ “enable length snapping” unchecked. For #3 I set Units precision to Architectural 1/64" w/ “enable length snapping” unchecked. I can observe no difference between these tests. When zoomed in VERY CLOSE, the vertices are separated between the groups at the very points to which they were snapped. I would attributed this to display inaccuracy, but when I try to draw an intersecting plane using these vertices, it is not always coplanar. My best solution: “QUIT DOING THAT”. Other ideas?

The first things I would do to make your modelling more accurate would be to change the Camera to Perspective from Parallel Projection and change either the background colour or the front face colours so they aren’t both white.

1 Like

[quote=“hikerider, post:9, topic:49592”]
Other ideas?
Firsts order is to under stand what your design , if the is what you are doing, requirements are. I assume you are building more than 1 step. Depending on you locale (usually specified by codes and enforcement folks )there are design specs on stairs , the railing, the spacing between balusters if any, the allowed variation in the step rise( careful on this it may be abt 1/6"), the range allowed for the rise plus tread length, landing design, etc …, they will not spec for just a couple of steps. There are numerous tuts on the net for you to learn what / how to design a stair and suggest you read some of those.
For the problem at hand my preference is to always use components, do not use fractions , 3 place decimal should be ok for you, always use inference locking until you get more use time with SU. IMHO you should not have to be changing units setting during you design process.
If your application is complicated suggest you start with say a simple 10 step straight design until you get the " hang" of things.
Good Luck, former city inspector :neutral_face:

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.