Pipe pushed through solid wall-Unable to delete faces


#1

HI, I’m constructing a darinage sump, with a 225mm twin wall pipe layed through a 100mm concrete wall. Having drawn the sump, I’ve pushed the pipe through the wall, but am unable to delete the two wall faces “inside” the pipe. Can anyone please tell me how to delete these two internal faces, and if possible, where I went wrong when Pushing/Pulling the pipe through.
Once corrected, I need to rotate the pipe around 15degrees on the horizontal plane, creating an eliptical entrance/exit to the wall.
Many ThanksOrchardCulvertSump-2018.skp (81.3 KB)


#2

Which version of SketchUp are you using exactly? Your profile is confusing. There is no 2016 free web version.

You need to edit the wall group to add the hole. Draw a cylinder inside the group where you want the hole and use Push/Pull to push it through. Then use Intersect Faces to create intersections and erase the unneeded stuff. You used Intersect Faces but you didn’t have the wall group open for editing so the intersection edges aren’t inside the group.

If you want the hole to go straight through instead of at an angle, drawing a circle on the face of the wall and pushing it through would work. Since you want the pipe at an angle, you should draw the elliptical hole in the first place.


#3

Many Thanks for your prompt reply.
Re: Version, I need to Update profile, using 2018.
Your diagram is very useful, having tried to create an outlet pipe as well with the same result, I think I know where I went wrong. I’ll delete what I’ve done and start again. I assumed I’d need to create the tube first and then manipulate it afterwards.
I hadn’t used the “Intersect Faces” part. I’ll let you know how i get on.
Many Thanks again.


#4

So you’re using SketchUp Pro, then. Great! Then you can use the Trim tool from Solid Tools instead. I prefer Eneroth Solid Tools which is available in the Extension Warehouse.


#5

I’ll look at that too, getting there, but will have to leave now until tomorrow.


#6

Still struggling with this,I (think) I’ve followed your directions in that I’ve created the outside of the pipe and placed it in the correct location, Intersected the faces (inside and out), offset the pipe inwards to create the tube, but now the Push/Pull wont work because " cannot Push/Pull smoothed or curved surfaces" - I’m working on the flat end of the tube ?
Could you direct me to a more detailed explanation of the process ?
Many Thanks


#7

How about uploading the SKP file when you get it to the point where you’ve offset the edge of the circle and before pushing the center through.


#8

Hi Again, I’ve now shown “hidden geometry” and there is an odd faceted face to the cylinder ? :OrchardCulvertSump-2018.skp (120.5 KB)


#9

You can erase those hidden edges crossing the end face. Then Push/Pull will work.

You didn’t quite follow my instructions completey. If you want to use Trim from Eneroth Solid Tools or the native Solid Tools you need to leave the pipe component outside the box component and you need to make the box a solid by removing the face skinning the bottom of the opening.


#10

Hello again Dave, Persevered with model and eventually worked out I need to be working in the larger (?) component and then “intersect faces” with the inserted pipe - It just didn’t seem to work vice versa ?
I have now actually built the sump (took a full 1 metric tonne of concrete to complete !) but would like to finish drawing properly as a learning exercise - I have a more ambitious project in mind.
I seemed to have problems with parts of the extruded pipe either not actually being formed (non solid) and/or bits of the faces appearing on different layers etc - I think it may have to do with groups being nested ? i.e. one group being set inside another larger group ?
It took a lot of cleaning up to get most things where they should be.
I still have an issue with making the main chamber a solid - there is no surface around the inside edge of the hole (?) - I managed to edit the other hole to create a face by drawing in edges between opposite facets, but it doesn’t seem to want to let me do it on this side - can you see where I’m going wrong ?
I’ve got each component on a separate layer so that they can be hidden out of the way, and the top face is hidden so that I can look inside the walls.
(There are aslo some heavy black segments around the edge, are these significant ?OrchardCulvertSump-2018.skp (171.2 KB)


#11

The first thing that sticks out is that you are using layers incorrectly. Your model has edges and faces on layers other than Layer 0 and you have made the Main Chamber layer active. Both of these are not recommended. You can see that the Layer field in Entity Info is blank which indicates that the selection is on more than one layer. And the radio button is not set to Layer 0 where it should be.

I would also recommend that you do your modeling with the camera set to Perspective, not Parallel Projection.

You’ve got your straight pipe balled up somehow with a bunch of loose geometry outside the pipe group.

I think you should start from scratch. Leave layer 0 as active at all times and only assign groups and components to other layers.


#12

I’ve set up the file correctly for you and given you a target to shoot for. Make the one on the left look like the one on the right.


OrchardCulvertSump-2018 (2).skp (83.1 KB)

If you haven’t already done so, install Eneroth Solid Tools from the Extension Warehouse. Then use these steps:

  1. Get the Eneroth Trim tool.
  2. Click on the Main Chamber.
  3. Click on one of the cylinders.
  4. Click on the other cylinder.
  5. Hit the Space bar on the keyboard to get the Select tool.
  6. Double click on the near cylinder to open it for editing.
  7. Get the Offset tool and click and release on the end face of the cylinder. Move the cursor in toward the center a little. Let go of the mouse.
  8. Type the pipe wall thickness as the Offset distance. Hit Enter.
  9. Get the Push/Pull tool and push the new circle on the end of the cylinder through to the other end to make it a pipe.
  10. Right click off the geometry of the pipe component and choose Close component.

Look at but don’t modify the layers. They are all set as they should be. Do not change the radio button to a layer other than Layer 0.


#13

Once again, thank you so much for taking the time to respond. I’ve now got the Eneroth tools installed, followed your instructions, and seem to have got there. I hadn’t intentionally placed bits of geometry on different layers-perhaps I had looked at a layer to check something and simply forgotten to switch back to ‘0’ ?
I’ll try re-drawing the model from scratch now and see if I get there more easily - I really don’t want to start anything more complicated until I’ve managed the basics on this one !


#14

You should never change the active layer from Layer 0, there are only a few very limited reasons for doing so and unless you know them there is no reason to change it.
One of the ways raw geometry can end up on other layers is the unfortunate side effect of exploding a group/component, it dumps it’s bits on whatever layer the group was assigned to. There is a plugin by Tig called Layer watcher (I think) available from sketchucation that automatically corrects things like that.


#15

"One of the ways raw geometry can end up on other layers is the unfortunate side effect of exploding a group/component, it dumps it’s bits on whatever layer the group was assigned to. "
Thats probably more likely-I’d messed about editing the components, exploding and re-creating multiple times trying to get them right, it could easily have happened.
Although I’ve picked up lots of basic info from youtube video’s etc, they often don’t (can’t) go into the details like this-it would be a useful “side effect” to be aware of generally?
Thank you


#16

You really shouldn’t need to explode groups or components very often but when you do, the geometry remains highlighted. The first thing you should do after exploding to raw geometry is to set the layer back to Layer 0 in Entity Info.

This feature of SketchUp giving the group/component layer property to the stuff inside can be very useful if exploding a nested component or group. It would be nice if it didn’t do the same thing when the result of exploding is raw geometry. But it’s not so difficult to deal with when you know what’s happening.


#17

" But it’s not so difficult to deal with when you know what’s happening." - again, unintended consequences ?
I’ve re-started from scratch with the intention of re-creating my plan correctly, but am already running into issues of items not behaving as I expected.
Starting with a blank file, I created the base unit (Rectangle, Push/Pull) to create the solid. I then Saved it first as a Component, then as a Group. (This Instance is at the Origin) I then moved to “Base” Layer.
I dragged a second slab from the Component Tray (2nd. Instance to the right) and moved to “BaseCopy” Layer.
I then took a Copy of my original Instance (3rd. Instance to the Right) and moved to “BaseCopy2” Layer.
So far all appeared to be OK ?
I then opened the original for editing, and using the offset tool twice, created the base outline of the main chamber, and used Push/Pull to create height.
This is where is seems to have gone awry ?
I again tried to save the main chamber as a separate Component, and also as a separate Group, but when I moved the two pieces apart, enexpected bits of geometry also moved apart:
The top face of the slab within the chamber stayed stuck to the bottom of the chamber (since deleted), there was no bottom face to the walls of the chamber, and the back face of the slab had been dragged up with the chamber (since re-created)
Furthermore, I had expected that the copy components would also have been edited i.e. had the main chamber added, but they haven’t altered-which I thought was the purpose of Components (unless you deliberately make them unique)
So in a few very simple and basic moves, the whole model is rapidly falling apart-Are you able to point me to where I’m going wrong?
Many Thanks again.OrchardCulvertSump-2018-Redraw.skp (122.0 KB)


#18

Why do this?

You’ve managed to create a lot of unnecessary grouping. There’s some ungrouped edges in there as well. The chamber has no bottom face which prevents it from being considered solid.
Screenshot%20-%209_20_2018%20%2C%206_11_50%20AM

I don’t understand why you are making groups of entities after they had been components but the only way for copies to get the same editing as the one you are working on is if they are instances (copies) of the same component. They aren’t. There’s only one component instance in the whole model and it’s the base in the center.

I think that a large part of your confusion is due to your inconsistency with using groups and components. Start over and for the time being, just use components. Don’t make nested components. There’s no need for them to be nested and it is created management problems for you.

I’ve made another file for you to follow along with. The sump base is sitting at the origin already. Do exactly what I describe below on it. Do not open the sump base component for editing. Do not copy it. There are visuals in the background so you can see what you should have at each step.

OrchardCulvertSump-2018-ReRedraw.skp (56.2 KB)

  1. Get the Tape Measure tool and place two guideline across the corners of the sump base to identify the center. (You could use inferencing to identify the center but guidelines are easier to show in a screen shot. For now, just do as I say.) Then get the Rectangle tool. Hit Ctrl to make the tool draw the rectangle from the center. Click on the intersection of the guidelines and drag along one of them. Let go of the mouse and type to make a square 0.8m by 0.8m.
  2. Get the Offset tool and create offset edges 0.1m inside the square you drew in step 1.
  3. Right click on the face of the inner square and click Erase.
  4. Get the Push/Pull tool and pull the remaining face up to1.08m.
  5. Get the Select Tool (Space Bar) and triple click on the box you just created. This will select all of the attached edges and faces without selecting the sump base. Right click on it and choose Create Component or the default keyboard shortcut is G. Type a name and hit Enter.

That’s all there is to it. If you want to assign each part to a separate layer, wait until the components are made.


#19

I worked your example fine!


#20

Is there a difference therefore in your method of creating a rectangle from the centre out, and offsetting that, rather than my doing a double offset from teh outer edge, which looks identical ?
“Right click on the face of the inner square and click Erase.” - I would have expected that to have been the upper face of the base, so you effectively created a double skin i.e. one on the upper surface of the base, and one on the lower (unwanted) surface of the chamber ?
I have been able to separate the chamber from teh base in your drawing , with both parts remaining complete, yet it doesn’t show in Entity Info as being a solid, despite it being a component, and presumably complete ?
Re: Your other queries, I was using this as a learning exercise, and although unecessary, thought that creating components and then grouping the original, would have kept the geometry separate, and prevent it merging-which it clearly didn’t. Why did my base pull apart, despite being a group ? Once satisfied, I’d intending editing the original component to see the effect on the others.
“There’s only one component instance in the whole model and it’s the base in the center.” - I had expected that all three would have been components-does the original not then become a Component itself when you “make Component” ?
I’m very aware of taking up a lot of your time on my queries, for which I’m very grateful, do you recommend a particular source (knowledge articles or Youtube video’s etc.) that may give me a better understanding, without involving too much of your time ?
The unecessary Grouping was simply me re-doing the “make Group” in case I had got it wrong the first time
Regards