Photo match will not project photo textures and trim

Hi all! Trying to learn how to photo match. I have drawn the basic perspective lines/faces but don’t seem to be able to project the textures and trim. I thought maybe one of the lines wasn’t connecting properly but it doesn’t seem to be the case. Any ideas?

Do you have a face selected?
Some screenshots or the model itself would help sort it out

sounds like your lines may not of made a face? In example you can see it looks like they do in first attempt but are wrong. Once a face is formed it will look opaque and when selected have the blue dots on it. you have to go back to the photomatch tab to align the image and then apply textures.

1 Like

Thanks Mike and whiterabbit

I have just joined some rectangles and the faces are all shaded so not sure why it wont project the texture and trim. I started it from scratch again and it still wouldn’t work.

It does show the blue dots when selected…

How about sharing the SKP file so we can see what you have going on?

I just had an experience where I couldn’t project the photo on surfaces. It worked on a group, but it refused to work on a component. I don’t ever remember running into that before. Is that normal? Is that maybe what you’re experiencing? SU Pro 2019

Are you clicking on the “project photos from photo” button once you are in the photomatch view and maybe try with a face(s) selected? Sorry that may be obvious, but just checking.
Also check to see if faces are reversed.

Yep tried that!

No its not what I’m experiencing?

Do you have “shaded with texture” mode enabled, maybe the textures are there but not displaying??

Did you ever find a resolution to this?
Today I ran into a similar thing. When projecting a photo from Matched Photo onto a surface it will project the photo but will not trim the photo.

when I try it again I get a box that pops up and says “Overwrite existing materials? (Yes) (No)”
Doesn’t matter what I say it still won’t allow me to trim the material.

In the past I cold project a wall and trim the material and then save that as a unique texture. I could click project image on different selected surfaces, and create multiple textures from the same matched photo and it never asked me if I wanted to overwrite existing material, it would ask me if I wanted to trim material.

I don’t know if Fredo6 thrupaint has anything to do with it, but I was able to trim once in the file, then used thrupaint to wrap the image, and can’t trim since. I don’t know if that is a coincidence or has anything to do with it. I installed the extension with no luck.

I restarted my computer, created a new sketchup file imported a different photo and still can’t trim.
It’s like the Trim option has disappeared from existence.