Is Match Photo Just A Pipe Dream? It never works for me

I’ve never been able to get match photo to work properly and finally I have a project that should work since all I need to do is match up a construction trailer – it’s a fricken CUBE!! easy right… :frowning:

So this is it, we need to build a platform connecting the 2 doors and a couple of steps up. Don’t even need a plan really for this but I thought I would finally get to show a model against a real life photo. However when I use the trailer to set the vanishing points I can never get the dimensions in ketchup to line up with the photo, to get the walls the proper length I need to change the vanishing points and then everything looks a little off.

I notice the photo I have the trailer vertical edge is not mathematically straight up, so I am wondering is there a way to rotate a match photo or align the blue axis? Or do I need to rotate photos prior to importing? Or is this not the problem at all, wth am I doing wrong?

I will attach a photo that shows the dimensions and my sketchup file for any body interested in poking at this. (Its important to note that the vertical measurement on the photo is from the level of the roof down to the level of the white insulation on the ground–not the actual trailer

LRC Back Stairs.skp (2.7 MB)

Looking at your model, you seem to have everything lined up… Maybe I am confused about what is not working… Can you explain what you are wanting to happen or what is not working?

If you mean that you want the photo to show through on your model, hit the Project textures from photo button.

Or if you mean that’s it’s not exactly the right size, make the geometry a group, enter the group, use the measuring tape to define which line you want to edit, then type the right length, click enter, and the whole group will re-size proportionately. See my screencast (you’ll have to download cause the MP4 embed doesn’t seem to be working very well)

One key thing about Match Photo is that the image needs to be un-manipulated. That is uncropped and not rotated in an image editor. If you have the raw un-manipulated image right out of the camera, you should be able to set up the the vanishing points in SketchUp to make it work. Most users who struggle with Match Photo seem to skip that part.


the corners of the cube I made in sketchup don’t line up with the corners of the trailer in the photo photo and the vertical edges of the trailer don’t line up straight either

this is the original image out of an iPhone

Your model looks perfectly fine. If you’re referring to those green and red indicators, you don’t need to align them with your object, their length is meaningless. They are there to align directions of X and Y, that’s it.

If by “perfectly fine” you mean the model is acceptable for most purposes I would agree but I’m here trying to gain knowledge because this model is not perfect
I can line up the vanishing points so that I can have a cube that lines up perfectly with the photo but when I did that the dimensions were off. Any ideas how to fix this?

Have you checked the trailer to see that the corners are all vertical?

There are some basic limitations that may make it impossible to get perfect alignment using match photo. For example, if your camera was not pointed exactly horizontally there will be some amount of convergence to the vertical lines in the photo. There will be effectively three vanishing points, but match photo handles only two. Another example, many camera lenses have some amount of pincushion or barrel distortion that will bend edges that should have been straight. The straight lines set up by match photo won’t follow these bent edges perfectly.

How far off were the dimensions? There may be an ultimate limit due to the image pixels on both the photo and on your screen!


I agree and am ready to let this one slide – the whole trailer could have an imperceptible twist as well. All lenses distort, I remember reading something about the iPhone straightening out its photos so maybe they aren’t even “unmodified originals” to begin with.

When I posted I probably expressed too much frustration about this exact project, and everybody latched on to that. What I was really hoping for was some way of adjusting the blue axis (but this would likely only be implemented if Sketchup handled 3 vanishing points so at least I surmise why it’s not an option and likely won’t be in the future and just let it go…)

Thanks for your input everybody.

As filibis explained earlier, thats the right way to use match photo in sketchup, there are several tuts available on the youtube from where i learnt, u can also use the textures from the image and materials for quick modeling, here is some example i use match photo to build a model only from google earth street view images of dunedin, New Zealand.

And especially for straight edged structures as yours should be as easy as a walk in the park.


[quote=“calvinennis, post:8, topic:43638”]
If by “perfectly fine” you mean the model is acceptable for most purposes I would agree but I’m here trying to gain knowledge because this model is not perfect[/quote]

Well, you can’t really be sure whether the container is on a flawlessly flat ground or has pure vertical walls in real life or not. As you can see all those edges are off with same amount more or less. And the reason for that might be the container’s closer part is sitting on a slightly higher ground than far part. Also there might be camera related distortions or crops as mentioned before.
Thus i can say it’s perfectly fine because you did what is needed :slight_smile:

I’m not able to show it atm but if you know the vertical dimension you can drag at the blue axis to change the grid (dimension).

1 Like

I have always struggled to get photos to match reasonably well until I bought software that automatically corrected all the lens distortion. Even then lines won’t line up perfectly.

I must say I’m impressed with the Dunedin building using only Google street view. They are usually massively distorted.

This topic was automatically closed after 91 days. New replies are no longer allowed.