Performance Issues/Stutters

I have a file that is lagging so so much. What can i do to optimize? I’ve turned off fog, shadows, profiles even edges but its still slow. I can’t share the file because its 130 mb. Is there anything that i can do to make it faster?

use wetransfer and share the link here.

without seeing it, we can’t say. it could be 130mb or reasonable 3d modelling, but also 130mb of super high poly stuff.

and until we poke in it, it’s impossible to say

1 Like

WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free Here you go

yeah, so, 3M lines, but then again, it’s a wide terrain. so ok.

no material issue.

Capture d’écran 2024-03-03 à 12.01.36

lots of things to purge.

Capture d’écran 2024-03-03 à 12.01.53

weirdly enough, when I invert what’s visible (the smooth terrain instead of the layered one), it’s way smoother.

Right now I have a cleanup3 in progress, I’ll come back with more updates


Thank you, you are a life saver.

Ok, when saving, SU prompted me it solved A LOT of errors.

stuff like 2 lines at the same spot (connecting 2 identical endpoints) yet seen as 2 lines still

turns out, you also have a lot of faces inside :

it’s been built layer by layer, like an actual cardboard model. so there are faces inside, and on the sides, you have A LOT of extra lines that don’t have a use anymore.

Deleting the bottom faces made a few holes, here is how you’ll have to fill them back in
basically, when the layers were stacked, in some places, they didn’t “cut” or impact the face they were in contact with.

here is how to fill back the few holes. just line tool, and some patience.
'don’t forget to revert / orient faces so the white is visible, not the grey like in my example :sweat_smile: )

if you really need a bottom face, when you’re done patching the holes, you can treat the bottom face as a mega hole (just redraw one line and poof)

after all that cleanup, it’s WAY FASTER, like, “oh wow, it’s smooth now”

and it’s 28mb instead of 137

(I also moved your model on the origin, you were 1-4km away, it can add lag on big models)

1 Like

Capture d’écran 2024-03-03 à 12.36.08

by the way, we went from 3 337 939 lines to 418 385 for the same visible result.
That was the sluggish thing imo.
(reduces faces by half too, between the purged stuff and the extra inside / side faces…)

I used the following extensions :

  • material resizer to check if you had big ones. you didn’t.
  • CG impact report, it told me what components / groups were used or not, and after the purge, it told me what was removed.
  • Cleanup3, it allowed me to merge coplanar faces, and clean various little bits and things.

Also, in my sketchup preferences / general I have the “automatically solve issues” and “tell me what you’ve solved” turned on.
That way, if there are some geometry “illegal” things, SU will get rid of them and tell me.

1 Like

Thank you so much, i can work smoothly now. Have a good one!

1 Like