Pencil won't "cut out" piece, always hollow extrusion

This is a house roof and on the left side I’ve used the pencil tool to erase the edge of the triangle and separate the “soffit”. You can see the full roof is still together and I can extrude this. However, when I use the pencil tool to do the same thing on the right side, it disconnects the roof lines from the bottom of the triangle and causes the push/pull to become hollow.

I think I got lucky on the left side… would anyone be able to explain how I can reproduce this so I’m basically cutting out the soffit and leaving the roof frame entact?

Thank you!

No luck involved, it’s expected behavior. When you drew a line on one side you still have one surface that connects continuously all the way around the roof perimeter and includes the bottom section. Notice how the selection highlighting (blue) still includes the entire single surface. When you do the same on the other side, you have isolated the bottom section, now you have 2 surfaces, which will each push pull separately.

This is my guess, but maybe I misunderstand the problem. Attach your model here so we can see what you have going on. I don’t quite understand the hollow push pull part, or exactly what you are trying to achieve.

Bonjour, apparemment vous êtes dans un groupe. Personnellement j’éclaterai le groupe, j’effacerai la partie gauche et ferai une copie miroir de la partie droite avec l’axe de rotation au centre de la forme.!
Capture d’écran 2021-02-22 084844|690x279

Thank you, so that does make sense… I guess the real issue then is that when I push the top of the roof, it’s now hollow inside instead of being solid. Thank you for your help.

house roof.skp (2.3 MB)

Is this what you are hoping to see?

You have the end face divided into a bunch of regions. When you do that Push/Pull will create voids. It’s supposed to do that. You would expect it to do that for things like windows and doors. Except for the shape, it’s the same process.

I’m guessing you would really rather have something like on the right, below. Delay outlining for the rake and soffit until after you’ve extruded the room shape.

That’s because there is another face adjacent to the one you are pushing. In that situation SketchUp concludes you are trying to create a hole or dent into a larger surface, so it deletes the starting face of the extrusion. Your profile says you are on Mac, so, per the hint in the status bar, press option before you start the pushpull to tell SketchUp you want to keep that face.

Nice, option key worked. Thank you!

That’s exactly right. Using the option key that @slbaumgartner mentioned worked great. It looks like maybe you had a different method?

The issue with using the Option key is that you will often end up with internal faces which can create problems later or at least is just sloppy modeling that then takes extra steps to clean up. I did have a different method and showed it. I reduced the roof profile to the end face without the rake and soffit outlines. I made the roof 3D and then added the edges to do the detailing.

Your issue is basically the same thing that happens if you draw a floor plan on a 2D rectangle and then extrude the walls upward. Typically the faces will be reversed and there’ll be no faces on the bottoms of the walls. If you either delete the floor surface inside the walls before extruding or give the floor thickness before drawing the floor plan and extruding the walls, you won’t have the problem.