Cutting out objects from a rectangle that I pulled out


#1

I am making a sketchup diagram for woodworking.

I drew a rectangle and pulled it out 3/4".

I am trying to cut out a rectangle that is 7" x 3/4" x 3/4" that starts at an edge and goes into the board by 7 inches.

I did this once by pulling it out or in and I saw something that said something about an offset. and somehow i achieved the cutout but have no idea how I did this…

I am new but wated 3 videos and I am at least up and drawing some great plans!


#2

Please be a little more specific of what you are trying to accomplish. I don’t get it from your post.


#3

thanks you…forget all that…lemme try again

imagine a square piece of 3/4" plywood and I want to cut out a circle or rectangle or something from it and represent that in a sketch up drawing…regardless what the object is, i guess the technique will be the same…punching a hole through a rectangle .

big thank you…


#4

If you’re simply dealing with a single face, draw a closed outline of any shape. When you complete the closed outline, the lines should change from thick (profile) to thin, denoting an edge that cuts through a face. At this point, you need merely select the area to be removed and hit Delete.

If you’ve already Push/Pulled the face to some thickness, instead of deleting the outlined area, Push/Pull it through to the opposite face, stopping the extrusion right on that opposite face. You’ll end up with a shaped hole going all the way through the material represented by the two faces with faces all around the reveal of the opening forming the walls of the hole.

-Gully


#5

Some infos about the pushpull tool:


#6

This may help, stopping on the back edge will extrude it clean out. Go further passed the edge or stop in the middle you create a tube. Then as a single face just select the circle, rectangle and the delete key.


#7

wow…pretty aggravating…I am getting motion sickness working on this.

While I am able to create the shape, place it, pull it down flush to make the hole, then redraw 2 lines to create a face on the leading edge and delete that to open it-on one rectagle…I can’t do the exact same thing on the other piece of wood…

When I create the recatangle and place it and pull it down -this thing simply disappears…


#8

Push pull works very well!!! i must be missing something


#9

I’m sure you don’t realize it, but your messages are rather cryptic. I don’t know what significance you attach to push/pull working well in this context or, for that matter, what you mean by working. As far as references like “the other piece of wood…” what other piece of wood? I’m not even sure what that refers to. There is no wood. There are only edges and faces and the objects made from them, and the main property of these objects that is relevant here is their geometry, not their material. Or in your “motion sickness” post, I don’t really know what you’re talking about from, say, the word “aggravating” onward. What thing disappears?

Please describe what you’re trying to accomplish, how you’re going about it, and what actually happens in objective terms using concrete terminology, keeping in mind we don’t know what you’re thinking and can’t see through you eyes

-Gully


#10

Gully…

Imagine a 24" square piece of 3/4" plywood.

ok.

now i want to cut a piece of wood out of this piece of plywood that measures 3/4" x 3/4" x 7" from any edge into the square.

I want to create this object in SKETCHUP.

I was able to do it again by starting a new document creating a 3/4" thick rectangle. I then drew a 3/4" square (2 dimensional) on one of the edges and pushed this thing into the center for 7"…WORKED beautifully…

When I went back and opened my other SKETCHUP project to do the same thing on one of the objects in the same manner…it does not push in, I.E. cut into the object by 3/4 x 3/4 x 7"…I was approaching it differntly before…

i will need to get creative if you or anyone else cant picture this…

FUTZING around a lot in this program switching from orbit to pan gives me motion sickness…much like playing those horrible 1st person shooter video games-but you’ve probably can’t relate to that either…

Ideas?


#11

I just noticed something and I am sure I am about to make a breakthrough…I went back in to re-trace my steps and when

I re-drew the rectangle on the face of the object it said: either ON EDGE IN GROUP or ON FACE IN GROUP.

So, somthing about trying to push in on this group it does’t like i guess…So I think I have to somehow UNGROUP this object’s faces and edges so I can effect its properties…

SHA-BANG!!!

getting close eh? !!! thanks your patience


#12

Penrose,

It doesn’t have to be this hard, or your learning of important principles so dependent on accident. Every new user really owes it to himself to take a systematic tour of the program, including the tools, interface, types of supported entites and their properties, and essential modeling techniques. You can read from the Knowledge Base or view instructional videos–your choice.

Thus prepared, you can start building whatever projects you have in mind without immediately running into a brick wall. The fact that groups and components protect the geometry they contain and that you can’t affect the geometry inside of a group from outside of it–which you were trying to do–is absolutely basic. So is the fact that all you need to do to edit the contents of a group is to double-click it, or simply right-click > Edit group. Knowing both of these facts is essential to using the program effectively, and both would certainly be covered by basic program documentation.

-Gully


#13

Well thanks Professor for all that but you are right- I need to watch hours and hours of tutorials to arrive at a level of comparable expertise…I tried this program a few years ago and it was not good for me…I have made more progress n the last 36 hours than I could ever hope for and absolutely love this program…I am a quick start but his was driving me crazy…

simply right-click > Edit group

Thankyou-I really appreciate this- but if I have more questions i will not hesitate to ask…thanks again.


#14

i didnt mean to sound snarky, I appreciate your help for sure…I have been doing a lot with the projects I have been working on but, sometimes I arrive a the group>explode and sometimes I can arrive there…simply right-click> edit group is not an option, I am pouring through all pertinent resources but sometimes hit the brick and mortar…

thanks again


#15

Problem panel solved

So the issue was, there was an object onside this object that I couldn’t see and when I tried to push the rectangle in, the object inside prevented this. This kind of situation would not be coverd in the basic program documentation.


#16

Suggestion … any time you are drawing an object that you are going to Push/Pull (such as the flat sheet of plywood with two notches that you reference here) it will be easier to draw the complete profile in 2D (flat) before you Push/Pull it to its thickness (3/4".)

Put all the notches, holes and beveled edges into the piece; then extrude it to thickness. Use Select/All connected to make a Group (or make a Component if you will use multiples of this piece.)

Drilled holes into the edges go in after the Group is created, but use Edit Group (or double-click on the object) to get “inside” the Group. You will be amazed how much easier it is to Push a hole into the edge if you choose X-Ray from the Styles toolbar.


#17

WOW !!! This is great…I think I am going to start this project over from the beginning using your technique because there a few issues with my sketch up that doesn’t suit me! I can’t wait to try it this way…THANK YOU lots man!!!


#18

I know this is a rather old thread… but my god… the sheer rudeness and bs going on from a certain someone…

The poor guy explained himself almost perfectly MULTIPLE TIMES… I sure hope for everyone else in this community, that you learned some manners and social skills… Basically telling someone that they are stupid and incompetent isn’t right regardless of your ‘reasons’… He explained himself quite well, and instead of helping, you just gave him the run around and badmouthed him…

From the get go, he said he had a surface that he had already extruded into a 3D state. He wanted to male a hole inside of the already created object, but no matter what he tried doing, he could not get a hole inside of that 3D model. I myself am having that same exact issue. I made a model, and realized i needed to add in a hole. But when I go to push/pull the shape through the 3D object, it just makes a new object. It doesn’t create a hole inside the pre-existing object. Nothing is grouped, nothing is intersecting. Just a 2D circle drawn overtop one of a 3D rectangle’s faces. push/pulling just creates a cylinder that pokes out of the rectangle, or sits flush with the rectangle’s face. deleting the cylinder just deletes the entire push/pull as if what i had just done never happened. Its quite a weird situation.

But no, I wont be returning here to see if there is some sort of ‘answer’ to this, because there is an almost guarantee that all that will be posted is a ‘wow you’re dumb’ sort of reply, with no actual help. Just a 'i dont understand what you’re meaning. rectangle, cylinder? what are these? you make no sense. they dont exist."… cause yea, the original post suuuuure was cryptic alright… so cryptic that an apparent ‘expert’ can’t understand what a square or a hole is…


#19

Even though I made great progress in this program this year I find the program very difficult to master. It is discouraging because you can do so much and create some very complex diagrams. I haven’t returned to this “help” fest for any reason other than I lost interest trying to learn this thing. It is so easy to screw up and so easy to get very aggravated working on projects that I spend more time trying to make a gee-whizzz diagram than working on the project. I rediscoverd and dusted off some old realiable tools that have served me well since kindergarten: pencils and straight edges.

i’ll be back.