PDF export is removing all textures - SU2017Pro, SU2018Pro


#1

I’m hoping someone here will be able to figure this out. I’m using SketchUp Pro. Starting with the 2017 version the PDF export stopped exporting texture images. All materials with texture images export as solid colors. It’s even stripping out the Style’s background color. If it was grey the PDF shows it as white. I just downloaded the 2018 Pro version and it’s doing the same thing. As an added “bonus”, when I attempt to export a PDF from Layout it crashes the display driver. The complexity of the file seems to be irrelevant. The same issue occurs with a large building file, or a simple cube.

When the problem appeared with the 2017 version I went back and forth emailing tech support and they didn’t have a solution. Well, the final “solution” was to downgrade to SketchUp 2016 since the problem doesn’t happen with that version.

The problem occurs across all of our office computers. My best guess is there’s an issue between SketchUp 2017/2018 and the AMD FirePro V3900, but I have no way to verify that.

Has anyone else encountered this issue?


#2

What happens if you send your model to LayOut and export a PDF from there?


#3

The built-in SketchUp Pro PDF/EPS exporter has never exported textures, shadows or other raster effects. It exports vector graphics only.
If you “export” by printing to a PDF printer you must turn off the “Use high-accuracy HLR” print quality option that essentially forces the PDF printer to produce vector-only artwork identical to the built-in exporter. If the textures still go missing, try updating your graphics card driver.


#4

Well that’s odd. That’s one of the issues I was complaining about with SketchUp tech support and they never mentioned that. I guess I had it in my head that it worked at one point, but I just checked with SU2016 and you’re obviously correct. I typically export from Layout to PDF anyway.

That said, Layout 2018 is still crashing my display driver when I attempt to export a PDF. I’m getting the same error message that I got last year when exporting a PDF from Layout 2017.
File>Export>PDF…and the screen goes completely black, an error message pops up “Display driver stopped responding and has recovered”. At this point Layout is completely locked up and I have to force it closed. This started with LO2017. LO2016 works correctly.

I updated the graphics card driver this morning after the first crash with 2018, restarted, and it’s still happening.

I can keep using the 2016 programs, but the office is paying for the annual license upgrade so I’d like to figure out if this issue is software or hardware related.

Thanks


#5

I’ve managed to figure out what’s producing the crash in Layout. It’s the “Output Resolution” selection. “Medium” output works with 2016 and 2018 as it should. If I select “High”, which I prefer for presentation drawings, Layout 2018 crashes. High Output Resolution works fine with 2016.


#6

My work laptop has an AMD card (not my choice, and not FirePro) and it has worked quite OK with the non-demanding tasks I have given it. I’ll try if my high-resolution LayOut export I did the other day with my desktop (Nvidia) works. As it is a LayOut issue I would guess that it is not about plugins.


#7

When I searched the AMD website for drivers to your FirePro, the newest were more than a year old. My Radeon drivers are from last fall, with newer available. It seems that support for your card has ended.


#8

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.