Paid extension says unlicensed when used

I have a paid extension license that Sketchup does not recognize
If I log into Extension Warehouse my downloads shows the extension is active (5/5 activations)
Currently it’s installed on one computer but I get an unlicensed message
I purchased the extension 11/30/2020
It hasn’t worked since I went from standalone to subscription but I would like to try to use it

Something may be going on with my Sketchup account
I believe I originally used a different email address than I use now so that could be the problem

The extension in question is Eneroth View Memory

Any ideas?

2023 Mac Mini M2
OSX Sonoma 14.4.1
Sketchup 2024.0.483


Ping @ene_su . Maybe she can help you

I emailed her but no response
I had a similar issue a while back on some other extensions and someone from this board on the Sketchup Team made some change that enabled me to get the extensions working after that.
It did not fix the issue with View Memory however

I guess I’ll keep trying until someone that can help sees this post


That would be @colin.

Yes the email chain is still somewhere on the Forum


When you suggested to “ping” the publisher how did you mean? What messenger?

None. He already pinged her here on the forum. But he used the wrong account.
For her extension issues, she should be pinged using her personal account …


Same issue is happening to me with Eneroth Component Replacer.

I’ve been fiddling around trying to get this working since December. In December I had different issues. I couldn’t even get a dialog to repurchase the extension
So I’m inclined to repurchase at this point
I’ve wasted far more than $20 of my time trying to resolve it


Anyway, I suspect this is more a Sketchup Extension Warehouse issue than a Developer issue
I say that because when I originally had the problem in December it wasn’t only Eneroth extensions that were affected


1 Like

Component Replacer was one of my issues in December. @Colin with Sketchup Team did something that allowed it to work on my system
Good to know I’m not alone in this

As an update to my previous post I also get no opportunity to repurchase the extension, only to Install.
Windows or Mac


1 Like

I could see what needed fixing. I fixed Component Replacer for Rafael, and View Memory for Paul.

1 Like

Worked on my Windows 10 computer

On my Mac all I get is a tiny red dot with an x in it onscreen that goes away when I click it.

For what it’s worth, the extension when installed doesn’t appear on my Lord of the Toolbars selection list although four other Eneroth extensions I have installed do.


For issues with Extension Warehouse and its licenses you can contact SketchUp support directly.

Support solved the license issue

On my Mac the extension doesn’t work.
All I get is this when I try to Recall View… (attached)