OSX 3 monitors, different Sketchup resolution on external monitors

resolution
osx

#1

I’m using OX X El Capitan (10.11) on a Macbook Pro with a AMD Radeon R9 M370X 2048 MB. Both external monitors are running at 1920 x 1200 @ 60 Hz, 32-bit color. The internal laptop display is running at 2880 x 1800 Retina.

On the laptop display, the contents of the Sketchup window look as expected (see image 1). On either of the other displays, the contents of the Sketchup window become blocky as though they’ve dropped to a different resolution. Worth noting, no other app presents with this same resolution degradation.

Any suggestions as to what is going wrong and how I can fix it?
Thanks!


#2

SU is [most likey] setting the resolution based on the ‘start-up’ window resolution…

if you launch SU from the second monitor is the resolution better?

john


#3

John, I’m at a loss on how to start SU from the second monitor. I just start it from the Mac Launchpad. I don’t see an option to set a startup window or such.

Worth noting, when I 1st start SU, the initial window is displayed on my default laptop screen. However, the SIZE of the window (len x width) is set for my other monitor so it extends off the laptop screen onto the other monitor. It’s obviously has a mismatch in dimensions and monitors somewhere.

I’ve verified OpenGL support, etc.


#4

you need to have SU in the Dock to add more control…

then, hover the bottom of the second display to move the Dock to it, then launch SU from there…

once that’s done, there may be a Right-Click option to assign SU to that window…

NB: I haven’t run a second monitor for a while, so it may be a little different now…

john


#5

I am having the same problem, on an external lacie 324i monitor. Running Sketchup 2017 on a MacBook Pro (late 2013). Retina display, 16 GB Ram. Any help greatly appreciated.


#6

SketchUp doesn’t support antialiasing on Mac anymore, but it is honoring the available pixels. If I drag my SketchUp window from an external non-retina to my internal retina screen, all of the lines show more detail. That’s because there are more pixels to use.

You can turn on mirroring and see how much bigger the same SketchUp window appears on the non-retina screen. Or turn off mirroring and open a SketchUp window in each monitor. Then you’ll see how much more detail there is in the retina version.

In theory “Retina” means that the pixels are so close together that you can’t see any stepping at all, and if that was the case maybe antialiasing wouldn’t be needed. But with monitors Retina usually means it has about twice as many pixels across the screen. My iPhone is about 4 inches across and has 1334 pixels, my MacBook Pro is about 14 inches across and is 2880 pixels. That’s 326 pixels per inch for my phone and 220 pixels per inch for my Mac. It’s a lot less detailed, and you will still see stepping at a normal screen distance.

My 27 inch extermal monitor is 109 pixels per inch, and so the non-antialias lines in SketchUp look especially bad.


#7

Why would Sketchup turn it’s back on Mac users? That doesn’t make sense.


#8

I don’t know. I keep 2016 around in case I need a good looking screenshot.