ORBIT using a 3 button mouse


#1

From time to time the middle button orbit feature fails to function as well as at other times - orbit just doesn’t work smoothly or continuously.

I think that this is linked to more complex models though not on all occasions.

I have always used Logitech three button mice and have reset settings but to no benefit.

All ideas welcome.


#2

I find the middle button is generally the first to fail.
They tend to degrade over time, missing a click now and then, versus abruptly stop working.
Try a new mouse.

Several things may cause laggy model performance.

SketchUp relies heavily on the graphics card, its driver and the single core speed of the CPU.
It helps us help you if we know what hardware you’re working with.
Kindly fill in the missing hardware information in your profile.


Modeling technique has a tremendous impact upon model performance.
No amount of fancy hardware can compensate for poor modeling technique.

See this compendium of performance modeling techniques…
How do I make SketchUp Run Faster? — SketchUp Sage Site


#3

Hi Geo and thanks.

Working spec:

Windows 7 premium PC
Intel® Core ™ i3-2130 CPU @ 3.40GHz
8*GB RAM
64 bit OS
Graphics Card NVidia GForce 8400 GS Graphics memory 4095MB, Video memory 1024MB Open GL 2.1

The mouse is only a few months old and only fails to work on SketchUp.

I work on quite comeplex construction models and only have the groups on display that I need to work on at that time.

Presing and holding the mouse wheel only works for orbit part of the time.

All ideas welcome.


#4

Does the model respond immediately if you hit the Orbit shortcut O key in lieu of pressing the MMB?


#5

Yes it does


#6

So the model responds as expected when Orbit is initiated via the Keyboard.
But there’s an occasional glitch when Orbit is initiated via the MMB.

To me, that would indicate the issue is with the mouse, mouse settings or its driver.

What kind of mouse are we talking about?
Are you using the Windows OS driver or a driver provided by the mouse manufacturer?


#7

Your specs doen’t seem to match the 8600 GS - original spec is 256 MB graphics memory - that could cause plenty of lag - may appear to be a missed click.

An i3 CPU has very little internal memory (cache) which also causes lag.

Is your graphics driver up to date? Nvidia release new versions every few months.

SketchUp 2017 requires Open GL 3.0 - you could check what the minimum is for SU 2016.

In summary your PC hardware may be to blame - can you upgrade?


#8

H Geo

Using a Logitch M150 wireless mouse (with the paired K220 keyboard)

I think that Logitech PS2 is installed on first use - assuming that is the driver.

Problem now occurring on another model


#9

Hi GS

Thanks for your comments.

I used the O keyboard shortcut that GEO pionted out and that works fine so I am beginning to think that the mouse is at fault.

My PC meets the spec for SU Pro 2016. Maybe time for an upgrade though.


#10

I’m not able to find that model at Logitech Support.
Could it be a typo that should read … Logitech 510 ?

EDIT:

Found it
https://support.logitech.com/en_us/product/wireless-combo-mk220


#11

Hi Geo

Definitely a Logitech M150


#12

Logitech Support indicates it uses their SetPoint driver software.
Perhaps try updating the SetPoint driver, if that’s what your mouse is using.

SetPoint

  • Software Version:6.68.250
  • Last Update: 23-MAY-2018

https://support.logitech.com/en_us/product/wireless-combo-mk220/downloads


Other ideas…
• How old are the batteries in the mouse?
• Is anything blocking the Logitech USB receiver?
• Is there another input device in play, say, a 3D navigator still attached to the system?


#13

Hi

Updated Setpoint - no effect
Batteries fresh and the reveiver is max 500mm from the mouse.
‘O’ shortcut works perfectly. Mouse starts off okay and then works intermittently.
Probably the mouse. I’ll swop under warranty.
Thanks for all your advice.