I can't orbit with my logitech MX Anywhere 3 mouse

Hello everybody,

I have a little problem with my logitech MX Anywhere 3 mouse. When I pressing the central button of the mouse to orbit does not work, it only works if I press the central button with the left click. I would like to be able to orbit by pressing only the central button.

Any idea how I can configure it?

Thanks a lot

This seems to be coming up again, sounds like logitech drivers are playing havoc again.
Try removing the logitech drivers and use the generic mouse drivers.

This is what I had to do with my older wired mouses. The current Logitech Options driver has worked OK.

Check that your Logitech Options driver is up to date and update it if necessary.
Make sure that the scroll wheel button action is set to “Middle button”. The default may be something more handy with Internet browsing than SketchUp.

1 Like

I never had problems with Logitech mice, and I use them for as long as can remember…

MX3 Anywhere mice?

I’ve never had any problem with Logitech mice either but I haven’t had the MX3 Anywhere mouse. Recently others have reported problems related to that specific model.

No, have the MX master 2 and MX master 1 before that.
It’s basicly the same mouse as the anywhere exept that the anywhere is smaller and lighter.
So I guess the internals and firmware are roughly the same.

Edit: I see it’s about version 3 now, so internals and firmware are probably both updated and different from version 2.

I have an MX Master 3. No issues with any of its functions. Is it possible an update messed something up?

There was a period some years back when the drivers for certain species of rodent didn’t work and the simple fix was to use the generic drivers.
This behaviour seems to have started to come back in recent times. Several reports have shown up with the same issue.

I’ve had issues with the M570 trackball completely dropping out since the last OS 10 update. It will stop working all together, then start working again a few minutes later… I’ve tried uninstalling and reinstalling and updating firmware through the Logitech software, but the issue keeps happening. It’s random, infrequent, (very annoying when it does, I hate using the touch pad on my laptop) and happens across all my apps. My Logitech keyboard is unaffected.

The same problem here. Mouse pad was set to “middle button”. Sketchup shows the orbit icon but the function is not triggered. Does anyone have a solution for this?

What is a mouse pad? This thread is about a specific Logitech wireless mouse model (MX Anywhere 3). SketchUp doesn’t support touchpad gestures.

Thanks for the hint. The auto-completion has turned “mouse wheel” into “mouse pad”.
The problem is the same as with the creator of this thread. In the settings of Logi Options the scroll wheel is set to middle button and also the mode button (middle button) is, well, also set to middle button. So far I have used an MX Anywhere 2 which is configured the same way. With this model the orbit works in Sketchup. Also with an MX Master 3.

It might be worth mentioning that I use the MacOS version of Sketchup. I will test on another system if the mouse behaves the same and report here. But since I have a direct comparison with 3 models on my desk, one can assume that this is a specific problem of MX Anywhere 3.

It might be that Logitech Options has a weirdness that relates just to the singular mouse model. Just a short time ago I was about to buy one to use with my small laptop but the store had ran out of stock so I bought a second MX Master 2S instead. Seems that besides saving money I saved trouble as well.

I am having the same issue with the same mouse. I guess there are no workarounds yet. Tempted to get a 3Dconnexion mouse instead.

Logitech just pushed an update to Options, it may or may not help.

Gone thru 3 Logitech mice over the 18 months… all of them gone wacky with W10… single left click does a double left click unsolicited randomly . both wired and wireless… spent days tracking the problem… gave up in the end… seems both a combination of a faulty button spring and a driver / W10 update issue… but lots of complaints on Logitech forums

I don’t think that this is a W10 problem. In my experience the older cheap wired models break either by the wheel button going dead or the left button developing this double-click syndrome. We never used the Logitech drivers for mice without any fancy extra buttons. Someone has perhaps counted how many clicks a full-time CAD/BIM/3D Model operator performs per year, I guess that it is more than what an average office worker achieves.

I updated the MX 3 anywhere in MacOS Big Sur and it didn’t help. Now I can’t even press the left button on the left at the same time to make it orbit, nothing happens. Very disappointed.

Same problem here. MX Anywhere3. Big Sur.

Have you reached out to Logitech or checked their forums?