Mouse button fails after slow Sketchup

I have issues with the middle mouse button failing to orbit and pan. It works fine until the time I get a slow connection to Sketchup for Web, it freezes and fails to load my model, and then when it returns the middle mouse button no longer works to orbit.
The online mouse test also shows the middle button to not be working, although the webpage still scrolls when I press the middle button and then move the mouse.

This has happened on four separate mice now, its getting old.
What is a crashing Sketchup doing to my mouse settings?
And how do I fix it? I can’t find any settings for a mouse that help.
It’s stretching credulity to think that all my mice just happen to ‘fail’ in the same way after the same type of crash.

What mouse are you using?

Which browser are you using to access SketchUp for Web? Have you tried a different one? It possibly works best with Chrome…

I Use Linux ( Ubuntu ) not Windows and use Fire-Fox for a browser . . Can see anything any where

How large is the file size?

I’ve used a 2 microsoft and 2 HP mouses. nothing fancy, just bog standard 3 button mouse.

That’s really nice for you, thanks for that.

1 Like

1.4 MB, 989 KB, 233 KB and 92 KB. Tiny.

Edge. I cannot use other browsers.
It worked before, why does it NOT work now is the question.

Could have been a Windows update to Edge. I have had that happen with other sites.

That doesn’t explain how a different mouse will work immediately after one fails.

Rather than asking why how about you try a different browser and see if you get the same result. Then you will have a start toward troubleshooting the issue.

Can you rule out device failure? Previously I used cheap wired mouses, and they lasted somewhere between one and two years, typically the first thing to fail was the scroll wheel button.

Hi Lynne.

You realise you’re not really helping ?

Steven has a problem on his machine, with his mice, using edge.
I assume the edge thing is because it’s a company machine, and he can’t install another browser.

Your fist message was to say that on your machine it works.
Your second and third ones is about giving buying advices for a new machine. that’s not a solution for the orbit not working, and I’ve seen you post the same in another thread, not helping.

You’re wondering why people flag your messages as spam or off topic, that’s why. It’s off topic or spam. It’s not helping.


Now, back on the subject,

Because it’s tiny files, I’ll side with Box and Anssi, I would pin it on the mice or the browser.

indeed, most of my former mice lost their click and/or scroll.

To rule out device failure, can you test one (or more) of them on a different pc ? colleague, personal, friend… ? If it doesn’t work there either, could be the mouse misbehaving.

RLGL and box have a point, windows might have updated edge, and to rule out a browser issue, you’ll need to test another browser.

When you say you can’t, is it because you don’t have admin rights to install one ?

If so, you could try using a portable browser version.
here is a link to a portable firefox, you can install it on an USB stick (using a friend’s computer) and use it from the stick on your machine without installing anything on it.

1 Like

I’ve noticed this behavior as well, I’ve been using only Logitec G602 mice for a few years now and see this crop up every so often. Sometimes a change of batteries fixes it, other times, blowing in the scroll wheel can solve it (like a Nintendo cartage). I’ve had it with multiples of the same mouse have the issue and I think its the mouse wheel/click not registering well enough for SketchUp to accept the input. So I think it might just be a hardware issue exacerbated by SketchUp somehow. Either way its terribly irritating and your not the only one whose seen it!

1 Like

well, since 2007 I’ve used or 9 mice. and in 7 of them, the wheel scroll / click gave up first.
(one was forgotten in Tallin’s Airport, I’m using the 9th)
The wheel are usually made in softer plastic, it’ll make a bit less noise, but it also means that it’ll wear off first.

When scrolling, you don’t usually notice it until it’s too late, it’ll skip a beat, but so long as you zoom in and out, you might not see it.
but as the axle of the wheel gets thinner, the click might start skipping. and in Sketchup, you see it immediately.

My advice if you have a mouse with extra buttons is to always map one as middle click.
On my MX (and the 903 before that) I’ve remapped the “change dpi” button, it’s right next to the wheel.
Before that, I had it on the thumb.
It’ll have two effects, one, you won’t use the wheel as fast. two, it’s an actual button, no risk of sliding by mistake.

1 Like

Yeah, I think constantly mashing the wheel in SketchUp and the other applications is what kills em. Great Idea about remapping a button!

1 Like

Me and several others use the Logitech MX mouse. For me at least it’s the one that has lasted the longest for me and many other without failing. It’s pricy but worth it.

1 Like

Seriously, it just stopped working on my mouse. I jinxed myself…