Option key on mac invoke Circle tool

For some reason ‘option’ key is invoke the Circle tool as a default behaviour that breaks some other workflows like using ‘Option’ key while you are using Tape Measure should change it’s mode. Now it switching to the Circle tool instead.

Upon starting SketchUp, which tools is active?
Selection tool, or other?

That’s odd, the option key should be unassignable as a shortcut key for the very reason you are describing, because it’s a modifier. Your shortcuts are editable under Sketchup>Preferences>Shortcuts. You could check and see what shortcut is assigned to the circle tool, but the option key alone should not be a possibility.
Are you using a 3rd party keyboard, or a non-english keyboard?

Thanks for you answers, but the problem that I have not changed any default short keys. Circle tool has C key as a shortcut but at the same time when I am pressing ‘Alt’ circle tool becomes active from any tool. Here the video that shows this behaviour – https://www.dropbox.com/s/scgyxhomygjw4pr/Alt%20Problem.mp4?dl=0

Upon starting SketchUp, which tools is active?

Selection tool, or other?

Select is active when start.

ok, I have had some troubles with an extension, recently , which somehow managed to start sketchUp with the paint bucket tool. So, in your case it might be that there is an interfering extension. You can check by renaming the plugin folder which is located at a hidden folder here:
/Users/[USERNAME}/Library/Application Support/SketchUp 2017/SketchUp/Plugins
or use the ruby console in SketchUp and type : Sketchup.find_support_file('Plugins') Copy Paste the result.
(use finder>Go>Go to Folder)

rename the plugin folder (e.g. pluginsCOPY)
Stop SketchUp and restart.
test option key
If normal, it would be an extension that was bugging the Option key. Try to instal per extensions to figure out which one.

If nothing changed in the behavior :
Go to the folder again and rename Shortcuts.plist or delete.
Stop SketchUp and restart.
Check the behavior

1 Like

If you have a lot of extensions, try adding half at a time. If it stays fixed, add half of the remainder. If it’s broken, remove half of the first half you added, and test again.

Remove or add half of the remainder in a sort of ‘binary search’ - it’s usually the quickest way to work out which one is causing the problem, if it IS an issue triggered by an extension.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.